summaryrefslogtreecommitdiffstats
path: root/recipes-test/big-update/big-update_1.0.bb
diff options
context:
space:
mode:
authorRobert Danitz <robert@advancedtelematic.com>2017-06-14 11:54:58 +0200
committerRobert Danitz <robert@advancedtelematic.com>2017-06-14 11:54:58 +0200
commit266f988344d7abbe1a1921caaa813061fc56aa0e (patch)
tree45e0dae9999a1be3d2b4fd2b35bdcbadd9e85a13 /recipes-test/big-update/big-update_1.0.bb
parent5b7cf9b286ed81458ce8940c44643cf082000133 (diff)
downloadmeta-updater-266f988344d7abbe1a1921caaa813061fc56aa0e.tar.gz
adds two versions of a random, seeded big file
Diffstat (limited to 'recipes-test/big-update/big-update_1.0.bb')
-rw-r--r--recipes-test/big-update/big-update_1.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb
new file mode 100644
index 0000000..78852a9
--- /dev/null
+++ b/recipes-test/big-update/big-update_1.0.bb
@@ -0,0 +1,11 @@
1DESCRIPTION = "Example Package with 10MB of random, seeded content"
2LICENSE = "CLOSED"
3
4SRC_URI = "file://rand_file.py"
5
6FILES_${PN} = "/usr/lib/big-update"
7
8do_install() {
9 install -d ${D}/usr/lib/big-update
10 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M)
11}