summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-11-10 16:25:55 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2017-11-10 16:26:25 +0100
commit9e0bd0dfb5bba1ec0806cc3c31859a95c3460b4b (patch)
tree7f9233471d493a9189ff3abdb43f75136861723a /recipes-support
parentefb1433cc7ea7cae3ac60464a4c9164f6deeb26c (diff)
downloadmeta-updater-9e0bd0dfb5bba1ec0806cc3c31859a95c3460b4b.tar.gz
Add the newest version of libp11
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libp11/libp11_0.4.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-support/libp11/libp11_0.4.7.bb b/recipes-support/libp11/libp11_0.4.7.bb
new file mode 100644
index 0000000..7d77e90
--- /dev/null
+++ b/recipes-support/libp11/libp11_0.4.7.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10
11SRC_URI = "git://github.com/OpenSC/libp11.git"
12SRCREV = "da725ab727342083478150a203a3c80c4551feb4"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17
18# Currently, Makefile dependencies are incorrectly defined which causes build errors
19# The number of jobs is high
20# See https://github.com/OpenSC/libp11/issues/94
21PARALLEL_MAKE = ""
22EXTRA_OECONF = "--disable-static"
23
24do_install_append () {
25 rm -rf ${D}${libdir}/*.la
26 rm -rf ${D}${docdir}/${BPN}
27}
28
29FILES_${PN} = "${libdir}/engines/pkcs11.so \
30 ${libdir}/engines/libpkcs11${SOLIBS} \
31 ${libdir}/libp11${SOLIBS}"
32
33FILES_${PN}-dev = " \
34 ${libdir}/engines/libpkcs11${SOLIBSDEV} \
35 ${libdir}/libp11${SOLIBSDEV} \
36 ${libdir}/pkgconfig/libp11.pc \
37 /usr/include"