summaryrefslogtreecommitdiffstats
path: root/recipes-support/libp11/libp11_0.4.9.bb
diff options
context:
space:
mode:
authorArthur Taylor <codders@octomonkey.org.uk>2018-10-09 15:59:06 +0200
committerGitHub <noreply@github.com>2018-10-09 15:59:06 +0200
commit42972f0db05b4057a8c552cc10abfc8a634338be (patch)
treec851a320ef20bd4c9801b63b0d9fed7983cc39fe /recipes-support/libp11/libp11_0.4.9.bb
parent61c5d81118acbf97b36112ba21d701f29543524f (diff)
parentca33a287d8ed9161feb066720314aa7e2f1f6fec (diff)
downloadmeta-updater-42972f0db05b4057a8c552cc10abfc8a634338be.tar.gz
Merge pull request #396 from advancedtelematic/feat/import-installed-versions-rocko
Feat/import installed versions rocko
Diffstat (limited to 'recipes-support/libp11/libp11_0.4.9.bb')
-rw-r--r--recipes-support/libp11/libp11_0.4.9.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-support/libp11/libp11_0.4.9.bb b/recipes-support/libp11/libp11_0.4.9.bb
new file mode 100644
index 0000000..6d0165f
--- /dev/null
+++ b/recipes-support/libp11/libp11_0.4.9.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10RDEPENDS_${PN} += " opensc"
11
12SRC_URI = "git://github.com/OpenSC/libp11.git \
13 file://0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch"
14SRCREV = "e1210903291b1de9eabcad26e740a4b2fbcca692"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20# Currently, Makefile dependencies are incorrectly defined which causes build errors
21# if the number of jobs is high
22# See https://github.com/OpenSC/libp11/issues/94
23PARALLEL_MAKE = ""
24EXTRA_OECONF = "--disable-static"
25
26do_install_append () {
27 rm -rf ${D}${libdir}/*.la
28 rm -rf ${D}${docdir}/${BPN}
29}
30
31FILES_${PN} = "${libdir}/engines*/pkcs11.so \
32 ${libdir}/engines*/libpkcs11${SOLIBS} \
33 ${libdir}/libp11${SOLIBS}"
34
35FILES_${PN}-dev = " \
36 ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
37 ${libdir}/libp11${SOLIBSDEV} \
38 ${libdir}/pkgconfig/libp11.pc \
39 /usr/include"