summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:03:45 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:20:40 +0300
commitca40ecfb70cf8a9174f8b6ef7e417efefe62d9ca (patch)
tree492da8ffac7f80140176f443a884ca2765ef26f3 /recipes-sota/ostree
parent25deddaaa6647a59a752afe5e3d163d30e868abe (diff)
downloadmeta-updater-ca40ecfb70cf8a9174f8b6ef7e417efefe62d9ca.tar.gz
ostree_git.bb: Bug fixes
Fixes for OSTree recipe: * Export staging directories, host and build system, * Deploy installed files in /usr/lib and /usr/share. Bug-AGL: SPEC-194 Change-Id: Ieda8c03f24c571827e91b0e72acad515f0cf14ff Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-sota/ostree')
-rw-r--r--recipes-sota/ostree/ostree_git.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 37a2445..e085df0 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -22,11 +22,19 @@ FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
22 22
23BBCLASSEXTEND = "native" 23BBCLASSEXTEND = "native"
24 24
25export STAGING_INCDIR
26export STAGING_LIBDIR
27
25do_configure() { 28do_configure() {
26 NOCONFIGURE=true ./autogen.sh 29 NOCONFIGURE=true ./autogen.sh
27 oe_runconf 30 oe_runconf
28} 31}
29 32
33do_compile_prepend() {
34 export BUILD_SYS="${BUILD_SYS}"
35 export HOST_SYS="${HOST_SYS}"
36}
37
30do_install_append() { 38do_install_append() {
31 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 39 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
32 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service 40 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
@@ -37,5 +45,9 @@ do_install_append() {
37SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 45SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
38FILES_${PN} += " \ 46FILES_${PN} += " \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \ 47 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \
48 ${datadir}/gir-1.0 \
49 ${datadir}/gir-1.0/OSTree-1.0.gir \
40 ${libdir}/dracut/ \ 50 ${libdir}/dracut/ \
51 ${libdir}/girepository-1.0 \
52 ${libdir}/girepository-1.0/OSTree-1.0.typelib \
41" 53"