summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-09-02 17:55:48 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-09-12 14:58:42 +0200
commitd0d74fbff4709ab9b093ec7785794d7f82b8e7b3 (patch)
tree26b4cc34d9e92178b41d9ed8bb3b728535b81b2a /recipes-sota/ostree/ostree_git.bb
parent9f816bdb3da9412e334cb8f7a69b48523732dc77 (diff)
downloadmeta-updater-d0d74fbff4709ab9b093ec7785794d7f82b8e7b3.tar.gz
Build OSTree natively, and its dependencies as well
Bug-AGL: SPEC-245 Change-Id: Ia5631d786c3375ba3aa0bc6ac75ebaeb358e7b03 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb32
1 files changed, 21 insertions, 11 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 659ee83..0e53d25 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -4,24 +4,35 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 4
5inherit autotools-brokensep pkgconfig systemd 5inherit autotools-brokensep pkgconfig systemd
6 6
7INHERIT_remove_class-native = "systemd"
8
7SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
8SRCREV="v2016.9" 10SRCREV="v2016.9"
9 11
10S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
11 13
14BBCLASSEXTEND = "native"
15
12DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd" 16DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd"
17DEPENDS_remove_class-native = "systemd-native"
18
19RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz"
20RDEPENDS_${PN}_remove_class-native = "python-native"
13 21
14RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma" 22EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
23
24SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
25SYSTEMD_REQUIRED_class-native = ""
26
27SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
28SYSTEMD_SERVICE_${PN}_class-native = ""
15 29
16PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 30PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
31PACKAGECONFIG_class-native = ""
17PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,," 32PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
18 33
19EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
20
21FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" 34FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
22 35
23BBCLASSEXTEND = "native"
24
25export STAGING_INCDIR 36export STAGING_INCDIR
26export STAGING_LIBDIR 37export STAGING_LIBDIR
27 38
@@ -35,19 +46,18 @@ do_compile_prepend() {
35 export HOST_SYS="${HOST_SYS}" 46 export HOST_SYS="${HOST_SYS}"
36} 47}
37 48
49export SYSTEMD_REQUIRED
50
38do_install_append() { 51do_install_append() {
39 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 52 if [ -n ${SYSTEMD_REQUIRED} ]; then
40 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service 53 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
41 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service 54 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
42 fi 55 fi
43} 56}
44 57
45SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
46FILES_${PN} += " \ 58FILES_${PN} += " \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \ 59 ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
48 ${datadir}/gir-1.0 \ 60 ${datadir}/gir-1.0 \
49 ${datadir}/gir-1.0/OSTree-1.0.gir \ 61 ${datadir}/gir-1.0/OSTree-1.0.gir \
50 ${libdir}/dracut/ \
51 ${libdir}/girepository-1.0 \
52 ${libdir}/girepository-1.0/OSTree-1.0.typelib \
53" 62"
63