summaryrefslogtreecommitdiffstats
path: root/recipes-sota/aktualizr/aktualizr_git.bb
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-10-21 10:11:04 +0200
committerAnatoliy Odukha <aodukha@gmail.com>2020-11-03 17:51:54 +0200
commit8350960da91e314c7b40f4f90534d3b9f947be7e (patch)
tree4823c937218641956b2663ca60f4ecfa278bdbcf /recipes-sota/aktualizr/aktualizr_git.bb
parent2b4f422a3340e83fee711b19e15f6308431dc95c (diff)
downloadmeta-updater-8350960da91e314c7b40f4f90534d3b9f947be7e.tar.gz
aktualizr: Don't put unused configs in the image.feat/2020.10
Because every aktualizr package was depending on aktualizr-configs, all of the default configs were getting installed to /usr/lib/sota, despite that by default none of them were ever used on the device. That dependency has been removed. The provisioning recipes still install the recipes they need to the default location that aktualizr actually uses (/usr/lib/sota/conf.d). If you want to use anything else, a specific recipe should be created to do so. This change rendered the aktualizr-host-tools package useless, so it has been removed. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-sota/aktualizr/aktualizr_git.bb')
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 8f14984..111ba0a 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -7,8 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
7 7
8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" 8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native"
9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" 9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}"
10RDEPENDS_${PN}_class-target = "${PN}-configs ${PN}-hwid lshw" 10RDEPENDS_${PN}_class-target = "${PN}-hwid lshw"
11RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}"
12 11
13RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" 12RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind"
14 13
@@ -133,14 +132,12 @@ python split_hosttools_packages () {
133 bindir = d.getVar('bindir') 132 bindir = d.getVar('bindir')
134 133
135 # Split all binaries to their own packages. 134 # Split all binaries to their own packages.
136 do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) 135 do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='', prepend=False)
137} 136}
138 137
139PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" 138PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*"
140 139
141PACKAGES =+ "${PN}-host-tools ${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" 140PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib"
142
143ALLOW_EMPTY_${PN}-host-tools = "1"
144 141
145FILES_${PN} = " \ 142FILES_${PN} = " \
146 ${bindir}/aktualizr \ 143 ${bindir}/aktualizr \