summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 19:44:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-07-30 10:29:35 +0200
commit31a770d3c0cb22c9f4ece068208d2e6b2c28f1ee (patch)
tree45dc83314dc336239e82f5d084541c3143841ed6 /conf
parenta0d9835bad4c86416323b1055315fc1fb09bcde5 (diff)
downloadmeta-updater-31a770d3c0cb22c9f4ece068208d2e6b2c28f1ee.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/distro/poky-sota-systemd.conf2
-rw-r--r--conf/distro/poky-sota.conf2
-rw-r--r--conf/distro/sota.conf.inc8
-rw-r--r--conf/layer.conf12
-rw-r--r--conf/local.conf.nonostree.append8
-rw-r--r--conf/local.conf.systemd.append4
6 files changed, 18 insertions, 18 deletions
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf
index 4b7990f..33dd597 100644
--- a/conf/distro/poky-sota-systemd.conf
+++ b/conf/distro/poky-sota-systemd.conf
@@ -7,6 +7,6 @@ DISTRO_NAME = "OTA-enabled Linux"
7DISTRO_VERSION = "1.0" 7DISTRO_VERSION = "1.0"
8DISTRO_CODENAME = "sota" 8DISTRO_CODENAME = "sota"
9 9
10DISTRO_FEATURES_append = " systemd" 10DISTRO_FEATURES:append = " systemd"
11VIRTUAL-RUNTIME_init_manager = "systemd" 11VIRTUAL-RUNTIME_init_manager = "systemd"
12PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf" 12PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"
diff --git a/conf/distro/poky-sota.conf b/conf/distro/poky-sota.conf
index bfac90f..13444fd 100644
--- a/conf/distro/poky-sota.conf
+++ b/conf/distro/poky-sota.conf
@@ -6,4 +6,4 @@ DISTRO_NAME = "OTA-enabled Linux"
6DISTRO_VERSION = "1.0" 6DISTRO_VERSION = "1.0"
7DISTRO_CODENAME = "sota" 7DISTRO_CODENAME = "sota"
8 8
9IMAGE_INSTALL_append_sota = " ostree-booted" 9IMAGE_INSTALL:append:sota = " ostree-booted"
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index 99035de..f84b834 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -4,14 +4,14 @@
4# 4#
5# require conf/distro/sota.conf.inc 5# require conf/distro/sota.conf.inc
6 6
7DISTRO_FEATURES_append = " sota usrmerge" 7DISTRO_FEATURES:append = " sota usrmerge"
8DISTRO_FEATURES_NATIVE_append = " sota" 8DISTRO_FEATURES_NATIVE:append = " sota"
9INHERIT += " sota" 9INHERIT += " sota"
10# Prelinking increases the size of downloads and causes build errors 10# Prelinking increases the size of downloads and causes build errors
11USER_CLASSES_remove = "image-prelink" 11USER_CLASSES:remove = "image-prelink"
12 12
13# Enable reproducible builds. Use 0 as mtime, the same as OSTree is using. 13# Enable reproducible builds. Use 0 as mtime, the same as OSTree is using.
14INHERIT_remove = "reproducible_build" 14INHERIT:remove = "reproducible_build"
15INHERIT += "reproducible_build_simple" 15INHERIT += "reproducible_build_simple"
16 16
17export SOURCE_DATE_EPOCH = "0" 17export SOURCE_DATE_EPOCH = "0"
diff --git a/conf/layer.conf b/conf/layer.conf
index bce1439..672fed8 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -6,13 +6,13 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "sota" 8BBFILE_COLLECTIONS += "sota"
9BBFILE_PATTERN_sota = "^${LAYERDIR}/" 9BBFILE_PATTERN:sota = "^${LAYERDIR}/"
10BBFILE_PRIORITY_sota = "7" 10BBFILE_PRIORITY:sota = "7"
11 11
12LAYERDEPENDS_sota = "openembedded-layer" 12LAYERDEPENDS:sota = "openembedded-layer"
13LAYERDEPENDS_sota += "meta-python" 13LAYERDEPENDS:sota += "meta-python"
14LAYERDEPENDS_sota += "filesystems-layer" 14LAYERDEPENDS:sota += "filesystems-layer"
15LAYERSERIES_COMPAT_sota = "dunfell gatesgarth hardknott" 15LAYERSERIES_COMPAT:sota = "dunfell gatesgarth hardknott"
16 16
17SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \ 17SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
18 aktualizr-device-prov->aktualizr \ 18 aktualizr-device-prov->aktualizr \
diff --git a/conf/local.conf.nonostree.append b/conf/local.conf.nonostree.append
index ee56b69..5d0d065 100644
--- a/conf/local.conf.nonostree.append
+++ b/conf/local.conf.nonostree.append
@@ -1,11 +1,11 @@
1 1
2DISTRO_FEATURES_append = " systemd" 2DISTRO_FEATURES:append = " systemd"
3VIRTUAL-RUNTIME_init_manager = "systemd" 3VIRTUAL-RUNTIME_init_manager = "systemd"
4 4
5PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf" 5PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"
6 6
7SOTA_DEPLOY_CREDENTIALS ?= "1" 7SOTA_DEPLOY_CREDENTIALS ?= "1"
8PACKAGECONFIG_pn-aktualizr = "" 8PACKAGECONFIG:pn-aktualizr = ""
9 9
10IMAGE_INSTALL_append += "aktualizr" 10IMAGE_INSTALL:append += "aktualizr"
11IMAGE_INSTALL_append += "aktualizr-shared-prov" 11IMAGE_INSTALL:append += "aktualizr-shared-prov"
diff --git a/conf/local.conf.systemd.append b/conf/local.conf.systemd.append
index 12e0182..be2e281 100644
--- a/conf/local.conf.systemd.append
+++ b/conf/local.conf.systemd.append
@@ -3,7 +3,7 @@
3# It greatly helps diagnosing issues on testing devices but should be 3# It greatly helps diagnosing issues on testing devices but should be
4# carefully weighted against file system usage and flash device wear for 4# carefully weighted against file system usage and flash device wear for
5# production systems. Please refer to systemd's docs for more details 5# production systems. Please refer to systemd's docs for more details
6IMAGE_INSTALL_append += " systemd-journald-persistent" 6IMAGE_INSTALL:append += " systemd-journald-persistent"
7 7
8# Set resource limits for aktualizr service 8# Set resource limits for aktualizr service
9# 9#
@@ -12,4 +12,4 @@ IMAGE_INSTALL_append += " systemd-journald-persistent"
12#RESOURCE_CPU_WEIGHT_pn-aktualizr = "100" 12#RESOURCE_CPU_WEIGHT_pn-aktualizr = "100"
13#RESOURCE_MEMORY_HIGH_pn-aktualizr = "100M" 13#RESOURCE_MEMORY_HIGH_pn-aktualizr = "100M"
14#RESOURCE_MEMORY_MAX_pn-aktualizr = "80%" 14#RESOURCE_MEMORY_MAX_pn-aktualizr = "80%"
15IMAGE_INSTALL_append += " aktualizr-resource-control" 15IMAGE_INSTALL:append += " aktualizr-resource-control"