summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-06-22 09:29:26 +0200
committerGitHub <noreply@github.com>2020-06-22 09:29:26 +0200
commitbed1238b211417fa68bd8fcb301ce7d112da6ef1 (patch)
tree6f7f472c40d7f03afbd616be3bb28b4af32f47bf
parent80072521db9312965d8c52a09bbfb29a633d2274 (diff)
parent5e08158e9eae225ce74017f5ea51fdf1ba27943b (diff)
downloadmeta-updater-bed1238b211417fa68bd8fcb301ce7d112da6ef1.tar.gz
Merge pull request #722 from liuming50/fix-network-configuration-naming
meta: change virtual/network-configuration to network-configuration
-rw-r--r--classes/sota_m3ulcb.bbclass4
-rw-r--r--classes/sota_minnowboard.bbclass4
-rw-r--r--classes/sota_porter.bbclass4
-rw-r--r--classes/sota_qemux86-64.bbclass2
-rw-r--r--classes/sota_raspberrypi.bbclass2
-rw-r--r--conf/distro/poky-sota-systemd.conf2
-rw-r--r--conf/local.conf.nonostree.append2
-rw-r--r--lib/oeqa/selftest/cases/updater_qemux86_64.py2
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend2
-rw-r--r--recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb2
-rw-r--r--recipes-test/images/primary-image.bb2
-rw-r--r--recipes-test/images/secondary-image.bb2
12 files changed, 15 insertions, 15 deletions
diff --git a/classes/sota_m3ulcb.bbclass b/classes/sota_m3ulcb.bbclass
index e7fa9c2..7ea273d 100644
--- a/classes/sota_m3ulcb.bbclass
+++ b/classes/sota_m3ulcb.bbclass
@@ -8,5 +8,5 @@ OSTREE_BOOTLOADER ?= "u-boot"
8 8
9UBOOT_MACHINE_sota = "${@d.getVar('SOC_FAMILY').split(':')[1]}_ulcb_defconfig" 9UBOOT_MACHINE_sota = "${@d.getVar('SOC_FAMILY').split(':')[1]}_ulcb_defconfig"
10 10
11PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman" 11PREFERRED_RPROVIDER_network-configuration ?= "connman"
12IMAGE_INSTALL_append_sota = " virtual/network-configuration " 12IMAGE_INSTALL_append_sota = " network-configuration "
diff --git a/classes/sota_minnowboard.bbclass b/classes/sota_minnowboard.bbclass
index a907217..3128965 100644
--- a/classes/sota_minnowboard.bbclass
+++ b/classes/sota_minnowboard.bbclass
@@ -8,5 +8,5 @@ IMAGE_FSTYPES_remove_sota = "live hddimg"
8OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0" 8OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0"
9IMAGE_INSTALL_append = " minnowboard-efi-startup" 9IMAGE_INSTALL_append = " minnowboard-efi-startup"
10 10
11PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman" 11PREFERRED_RPROVIDER_network-configuration ?= "connman"
12IMAGE_INSTALL_append_sota = " virtual/network-configuration " 12IMAGE_INSTALL_append_sota = " network-configuration "
diff --git a/classes/sota_porter.bbclass b/classes/sota_porter.bbclass
index 80062e1..6c6fe70 100644
--- a/classes/sota_porter.bbclass
+++ b/classes/sota_porter.bbclass
@@ -7,5 +7,5 @@ IMAGE_BOOT_FILES_sota += "porter-bootfiles/*"
7OSTREE_BOOTLOADER ?= "u-boot" 7OSTREE_BOOTLOADER ?= "u-boot"
8UBOOT_MACHINE_sota = "porter_config" 8UBOOT_MACHINE_sota = "porter_config"
9 9
10PREFERRED_RPROVIDER_virtual/network-configuration ?= "connman" 10PREFERRED_RPROVIDER_network-configuration ?= "connman"
11IMAGE_INSTALL_append_sota = " virtual/network-configuration " 11IMAGE_INSTALL_append_sota = " network-configuration "
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass
index fc4aa7c..3dc2428 100644
--- a/classes/sota_qemux86-64.bbclass
+++ b/classes/sota_qemux86-64.bbclass
@@ -13,4 +13,4 @@ IMAGE_ROOTFS_EXTRA_SPACE = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', '655
13# fix for u-boot/swig build issue 13# fix for u-boot/swig build issue
14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc" 14HOSTTOOLS_NONFATAL += "x86_64-linux-gnu-gcc"
15 15
16IMAGE_INSTALL_append_sota = " virtual/network-configuration " 16IMAGE_INSTALL_append_sota = " network-configuration "
diff --git a/classes/sota_raspberrypi.bbclass b/classes/sota_raspberrypi.bbclass
index d5d89a9..744ba22 100644
--- a/classes/sota_raspberrypi.bbclass
+++ b/classes/sota_raspberrypi.bbclass
@@ -13,7 +13,7 @@ UBOOT_DTBO_LOADADDRESS = "0x06000000"
13IMAGE_INSTALL_append = " fit-conf" 13IMAGE_INSTALL_append = " fit-conf"
14 14
15DEV_MATCH_DIRECTIVE_pn-networkd-dhcp-conf = "Driver=smsc95xx lan78xx" 15DEV_MATCH_DIRECTIVE_pn-networkd-dhcp-conf = "Driver=smsc95xx lan78xx"
16IMAGE_INSTALL_append_sota = " virtual/network-configuration " 16IMAGE_INSTALL_append_sota = " network-configuration "
17 17
18PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot" 18PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot"
19UBOOT_ENTRYPOINT_sota ?= "0x00080000" 19UBOOT_ENTRYPOINT_sota ?= "0x00080000"
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf
index 0dc50b0..4b7990f 100644
--- a/conf/distro/poky-sota-systemd.conf
+++ b/conf/distro/poky-sota-systemd.conf
@@ -9,4 +9,4 @@ DISTRO_CODENAME = "sota"
9 9
10DISTRO_FEATURES_append = " systemd" 10DISTRO_FEATURES_append = " systemd"
11VIRTUAL-RUNTIME_init_manager = "systemd" 11VIRTUAL-RUNTIME_init_manager = "systemd"
12PREFERRED_RPROVIDER_virtual/network-configuration ??= "networkd-dhcp-conf" 12PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"
diff --git a/conf/local.conf.nonostree.append b/conf/local.conf.nonostree.append
index 0e63e98..ee56b69 100644
--- a/conf/local.conf.nonostree.append
+++ b/conf/local.conf.nonostree.append
@@ -2,7 +2,7 @@
2DISTRO_FEATURES_append = " systemd" 2DISTRO_FEATURES_append = " systemd"
3VIRTUAL-RUNTIME_init_manager = "systemd" 3VIRTUAL-RUNTIME_init_manager = "systemd"
4 4
5PREFERRED_RPROVIDER_virtual/network-configuration ??= "networkd-dhcp-conf" 5PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"
6 6
7SOTA_DEPLOY_CREDENTIALS ?= "1" 7SOTA_DEPLOY_CREDENTIALS ?= "1"
8PACKAGECONFIG_pn-aktualizr = "" 8PACKAGECONFIG_pn-aktualizr = ""
diff --git a/lib/oeqa/selftest/cases/updater_qemux86_64.py b/lib/oeqa/selftest/cases/updater_qemux86_64.py
index 08220f4..dfcb8e0 100644
--- a/lib/oeqa/selftest/cases/updater_qemux86_64.py
+++ b/lib/oeqa/selftest/cases/updater_qemux86_64.py
@@ -130,7 +130,7 @@ class SharedCredProvTestsNonOSTree(SharedCredProvTests):
130 self.append_config('DISTRO = "poky"') 130 self.append_config('DISTRO = "poky"')
131 self.append_config('DISTRO_FEATURES_append = " systemd"') 131 self.append_config('DISTRO_FEATURES_append = " systemd"')
132 self.append_config('VIRTUAL-RUNTIME_init_manager = "systemd"') 132 self.append_config('VIRTUAL-RUNTIME_init_manager = "systemd"')
133 self.append_config('PREFERRED_RPROVIDER_virtual/network-configuration ??= "networkd-dhcp-conf"') 133 self.append_config('PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"')
134 self.append_config('PACKAGECONFIG_pn-aktualizr = ""') 134 self.append_config('PACKAGECONFIG_pn-aktualizr = ""')
135 self.append_config('SOTA_DEPLOY_CREDENTIALS = "1"') 135 self.append_config('SOTA_DEPLOY_CREDENTIALS = "1"')
136 self.append_config('IMAGE_INSTALL_append += "aktualizr"') 136 self.append_config('IMAGE_INSTALL_append += "aktualizr"')
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
index b3633cc..cd1b95d 100644
--- a/recipes-connectivity/connman/connman_%.bbappend
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -1 +1 @@
RPROVIDES_${PN} += "virtual/network-configuration" RPROVIDES_${PN} += "network-configuration"
diff --git a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
index 40a3958..20a1a17 100644
--- a/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
+++ b/recipes-connectivity/networkd-dhcp-conf/networkd-dhcp-conf.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
6 6
7inherit systemd 7inherit systemd
8 8
9RPROVIDES_${PN} = "virtual/network-configuration" 9RPROVIDES_${PN} = "network-configuration"
10 10
11SRC_URI = " \ 11SRC_URI = " \
12 file://20-wired-dhcp.network \ 12 file://20-wired-dhcp.network \
diff --git a/recipes-test/images/primary-image.bb b/recipes-test/images/primary-image.bb
index ba1dc1f..e6896ea 100644
--- a/recipes-test/images/primary-image.bb
+++ b/recipes-test/images/primary-image.bb
@@ -5,7 +5,7 @@ SUMMARY = "A minimal Uptane Primary image running aktualizr, for testing with a
5LICENSE = "MPL-2.0" 5LICENSE = "MPL-2.0"
6 6
7IMAGE_INSTALL_remove = " \ 7IMAGE_INSTALL_remove = " \
8 virtual/network-configuration \ 8 network-configuration \
9 " 9 "
10 10
11IMAGE_INSTALL_append = " \ 11IMAGE_INSTALL_append = " \
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb
index 7db2c68..22fb7f3 100644
--- a/recipes-test/images/secondary-image.bb
+++ b/recipes-test/images/secondary-image.bb
@@ -16,7 +16,7 @@ IMAGE_INSTALL_remove = " \
16 aktualizr-device-prov \ 16 aktualizr-device-prov \
17 aktualizr-device-prov-hsm \ 17 aktualizr-device-prov-hsm \
18 aktualizr-uboot-env-rollback \ 18 aktualizr-uboot-env-rollback \
19 virtual/network-configuration \ 19 network-configuration \
20 " 20 "
21 21
22IMAGE_INSTALL_append = " \ 22IMAGE_INSTALL_append = " \