summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-30 13:34:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-04-30 13:51:24 +0200
commit872d205f5a1fee757bc0a10765876a34866efb12 (patch)
tree84a3e6d37f936165c539be6e9c5fcc87abd18ad9
parente07c5478b9cabfba6cb94c8056ff124f2d1037c5 (diff)
downloadmeta-updater-872d205f5a1fee757bc0a10765876a34866efb12.tar.gz
aktualizr: drop unnecessary do_configure_prepend
* fails with latest oe-core/master with: https://git.openembedded.org/openembedded-core/commit/meta/classes/cmake.bbclass?id=0fb6280432a36985590d9a714a5f11164aaebb51 because this prepend does "cd ${S}" and doesn't go back to ${B} and cmake_do_configure function doesn't cd to ${B} anymore, resulting in: | CMake Error at CMakeLists.txt:42 (message): | Aktualizr does not support building in the source tree. Please remove | CMakeCache.txt and the CMakeFiles/ directory, then create a subdirectory to | build in: mkdir build; cd build; cmake .. * drop this whole do_configure_prepend as git-native works fine: aktualizr-native/1.0+gitAUTOINC+1255aa24fe-7/git$ grep Setting ../temp/log.do_configure -- Setting version to 2020.10-0-g1255aa24f aktualizr/1.0+gitAUTOINC+1255aa24fe-7/temp$ grep Setting ../temp/log.do_configure -- Setting version to 2020.10-0-g1255aa24f aktualizr/1.0+gitAUTOINC+1255aa24fe-7/build$ which git /OE/build/oe-core/tmp-musl/hosttools/git aktualizr/1.0+gitAUTOINC+1255aa24fe-7/build$ grep GIT CMakeCache.txt GITCOMMAND:FILEPATH=/OE/build/oe-core/tmp-musl/hosttools/git GIT_EXECUTABLE:FILEPATH=/OE/build/oe-core/tmp-musl/hosttools/git //ADVANCED property for variable: GITCOMMAND GITCOMMAND-ADVANCED:INTERNAL=1 //ADVANCED property for variable: GIT_EXECUTABLE GIT_EXECUTABLE-ADVANCED:INTERNAL=1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 111ba0a..ecfbd2b 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -70,14 +70,6 @@ RESOURCE_CPU_WEIGHT = "100"
70RESOURCE_MEMORY_HIGH = "100M" 70RESOURCE_MEMORY_HIGH = "100M"
71RESOURCE_MEMORY_MAX = "80%" 71RESOURCE_MEMORY_MAX = "80%"
72 72
73do_configure_prepend() {
74 # CMake has trouble finding yocto's git when cross-compiling, let's do this step manually
75 cd ${S}
76 if [ ! -f VERSION ]; then
77 ./scripts/get_version.sh > VERSION
78 fi
79}
80
81do_compile_ptest() { 73do_compile_ptest() {
82 cmake_runcmake_build --target build_tests "${PARALLEL_MAKE}" 74 cmake_runcmake_build --target build_tests "${PARALLEL_MAKE}"
83} 75}