summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-03 22:11:02 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-04-03 22:13:48 +0200
commit5ae002c5a7c83f1b78514d55af0910b9b18e374d (patch)
treebd87c9bfd3e9ca9f9356820df7e95870368f37b5
parenta8aaf6fa741ebce0daa54838abad933505fb325b (diff)
downloadmeta-updater-5ae002c5a7c83f1b78514d55af0910b9b18e374d.tar.gz
fit-conf, ostree-initrd, slcand-start: use COMMON_LICENSE_DIR instead of COREBASE in LIC_FILES_CHKSUM
* fixes slcand-start which fails since LICENSE file was changed in 2019 with: https://git.openembedded.org/openembedded-core/commit/LICENSE?id=f8c9c511b5f1b7dbd45b77f345cb6c048ae6763e WARNING: slcand-start-1.0-r0 do_populate_lic: ${COREBASE}/LICENSE is not a valid license file, please use '${COMMON_LICENSE_DIR}/MIT' for a MIT License file in LIC_FILES_CHKSUM. This will become an error in the future ERROR: slcand-start-1.0-r0 do_populate_lic: QA Issue: slcand-start: The LIC_FILES_CHKSUM does not match for file://oe-core/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 slcand-start: The new md5 checksum is b97a012949927931feb7793eee5ed924 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-sota/fit-conf/fit-conf.bb2
-rw-r--r--recipes-sota/ostree-initrd/ostree-initrd.bb2
-rw-r--r--recipes-support/slcand-start/slcand-start.bb4
3 files changed, 3 insertions, 5 deletions
diff --git a/recipes-sota/fit-conf/fit-conf.bb b/recipes-sota/fit-conf/fit-conf.bb
index f24a94a..f409b9b 100644
--- a/recipes-sota/fit-conf/fit-conf.bb
+++ b/recipes-sota/fit-conf/fit-conf.bb
@@ -1,6 +1,6 @@
1SUMMARY = "FIT image configuration for u-boot to use" 1SUMMARY = "FIT image configuration for u-boot to use"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 4
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb
index 26525c8..e7bd929 100644
--- a/recipes-sota/ostree-initrd/ostree-initrd.bb
+++ b/recipes-sota/ostree-initrd/ostree-initrd.bb
@@ -1,6 +1,6 @@
1SUMMARY = "Initramfs for booting into libostree managed system" 1SUMMARY = "Initramfs for booting into libostree managed system"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 4
5SRC_URI = "file://init.sh" 5SRC_URI = "file://init.sh"
6 6
diff --git a/recipes-support/slcand-start/slcand-start.bb b/recipes-support/slcand-start/slcand-start.bb
index dfefaea..566507b 100644
--- a/recipes-support/slcand-start/slcand-start.bb
+++ b/recipes-support/slcand-start/slcand-start.bb
@@ -1,8 +1,6 @@
1SUMMARY = "Mock smartcard for aktualizr" 1SUMMARY = "Mock smartcard for aktualizr"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6 4
7inherit systemd 5inherit systemd
8 6