summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-03-12 15:41:44 +0100
committerLaurent Bonnans <laurent.bonnans@here.com>2019-03-12 16:00:31 +0100
commit7a39c14aa24be4cac100ba2beaf13d52a382f719 (patch)
tree7db30479efae5f322144f30f331f6aaacdb43cee
parent26221695a4441a3cfaa7e6851d7efbbbe16fb4ee (diff)
downloadmeta-updater-test/OTA-2137/ptest-run.tar.gz
Save space in deployed aktualizr ptesttest/OTA-2137/ptest-run
* remove whole RIOT repo * remove intermediary static libraries, only useful during build Should be around 500MB saving in total Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rwxr-xr-xrecipes-sota/aktualizr/aktualizr_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 2753c81..49c4e5e 100755
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -71,8 +71,11 @@ do_install_ptest() {
71 cp -r ${B}/ ${D}/${PTEST_PATH}/build 71 cp -r ${B}/ ${D}/${PTEST_PATH}/build
72 cp -r ${S}/ ${D}/${PTEST_PATH}/src 72 cp -r ${S}/ ${D}/${PTEST_PATH}/src
73 73
74 # remove bogus elf file 74 # remove huge external unused repository
75 rm ${D}/${PTEST_PATH}/src/partial/extern/RIOT/cpu/esp32/bin/bootloader.elf 75 rm -rf ${D}/${PTEST_PATH}/src/partial/extern/RIOT
76
77 # remove huge build artifacts
78 find ${D}/${PTEST_PATH}/build/src -name "*.a" -delete
76 79
77 # fix the absolute paths 80 # fix the absolute paths
78 find ${D}/${PTEST_PATH}/build -name "CMakeFiles" | xargs rm -rf 81 find ${D}/${PTEST_PATH}/build -name "CMakeFiles" | xargs rm -rf