diff options
author | Anton Gerasimov <anton.gerasimov@openmailbox.org> | 2017-11-14 10:00:21 +0100 |
---|---|---|
committer | Anton Gerasimov <anton.gerasimov@openmailbox.org> | 2017-11-14 10:00:21 +0100 |
commit | 53a0094633230b08cc56f0a6fc46fb289d27e31f (patch) | |
tree | 12ec617d6a397572141276b46f05a130a8bc4c32 | |
parent | eceaca216c73bd188821e111a73723069668e1f3 (diff) | |
download | meta-updater-rockocandidate.tar.gz |
Syntax fixes for compatibility with Rockorockocandidate
-rw-r--r-- | classes/image_types_ostree.bbclass | 4 | ||||
-rw-r--r-- | classes/image_types_ota.bbclass | 2 | ||||
-rw-r--r-- | classes/sota_qemux86-64.bbclass | 2 | ||||
-rw-r--r-- | recipes-support/util-linux/util-linux_%.bbappend | 3 |
4 files changed, 4 insertions, 7 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 1f8e195..07ff711 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -2,7 +2,7 @@ | |||
2 | 2 | ||
3 | inherit image | 3 | inherit image |
4 | 4 | ||
5 | IMAGE_DEPENDS_ostree = "ostree-native:do_populate_sysroot \ | 5 | do_image_ostree[depends] += "ostree-native:do_populate_sysroot \ |
6 | openssl-native:do_populate_sysroot \ | 6 | openssl-native:do_populate_sysroot \ |
7 | coreutils-native:do_populate_sysroot \ | 7 | coreutils-native:do_populate_sysroot \ |
8 | virtual/kernel:do_deploy \ | 8 | virtual/kernel:do_deploy \ |
@@ -159,7 +159,7 @@ IMAGE_CMD_ostree () { | |||
159 | } | 159 | } |
160 | 160 | ||
161 | IMAGE_TYPEDEP_ostreepush = "ostree" | 161 | IMAGE_TYPEDEP_ostreepush = "ostree" |
162 | IMAGE_DEPENDS_ostreepush = "aktualizr-native:do_populate_sysroot" | 162 | do_image_ostreepush[depends] += "aktualizr-native:do_populate_sysroot" |
163 | IMAGE_CMD_ostreepush () { | 163 | IMAGE_CMD_ostreepush () { |
164 | # Print warnings if credetials are not set or if the file has not been found. | 164 | # Print warnings if credetials are not set or if the file has not been found. |
165 | if [ -n "${SOTA_PACKED_CREDENTIALS}" ]; then | 165 | if [ -n "${SOTA_PACKED_CREDENTIALS}" ]; then |
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass index 09c30ff..b15178a 100644 --- a/classes/image_types_ota.bbclass +++ b/classes/image_types_ota.bbclass | |||
@@ -11,7 +11,7 @@ inherit image | |||
11 | 11 | ||
12 | OSTREE_BOOTLOADER ??= 'u-boot' | 12 | OSTREE_BOOTLOADER ??= 'u-boot' |
13 | 13 | ||
14 | IMAGE_DEPENDS_otaimg = "e2fsprogs-native:do_populate_sysroot \ | 14 | do_image_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \ |
15 | ${@'grub:do_populate_sysroot' if d.getVar('OSTREE_BOOTLOADER', True) == 'grub' else ''} \ | 15 | ${@'grub:do_populate_sysroot' if d.getVar('OSTREE_BOOTLOADER', True) == 'grub' else ''} \ |
16 | ${@'virtual/bootloader:do_deploy' if d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot' else ''}" | 16 | ${@'virtual/bootloader:do_deploy' if d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot' else ''}" |
17 | 17 | ||
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass index 5ec4f69..8eed429 100644 --- a/classes/sota_qemux86-64.bbclass +++ b/classes/sota_qemux86-64.bbclass | |||
@@ -5,7 +5,7 @@ IMAGE_FSTYPES_remove = "wic" | |||
5 | 5 | ||
6 | # U-Boot support for SOTA | 6 | # U-Boot support for SOTA |
7 | PREFERRED_PROVIDER_virtual/bootloader_sota = "u-boot-ota" | 7 | PREFERRED_PROVIDER_virtual/bootloader_sota = "u-boot-ota" |
8 | UBOOT_MACHINE_sota = "qemu-x86_defconfig" | 8 | UBOOT_MACHINE_sota = "qemu-x86_64_defconfig" |
9 | OSTREE_BOOTLOADER ?= "u-boot" | 9 | OSTREE_BOOTLOADER ?= "u-boot" |
10 | 10 | ||
11 | OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda" | 11 | OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda" |
diff --git a/recipes-support/util-linux/util-linux_%.bbappend b/recipes-support/util-linux/util-linux_%.bbappend deleted file mode 100644 index d653bb2..0000000 --- a/recipes-support/util-linux/util-linux_%.bbappend +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | PACKAGES_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native', ' ', d)}" | ||
2 | |||
3 | PACKAGES_append_class-native = "${@' util-linux-pylibmount-native' if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d) and bb.utils.contains('PACKAGECONFIG', 'pylibmount', True, False, d) else ' '}" | ||