summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2019-12-07 12:29:04 +0100
committerMing Liu <liu.ming50@gmail.com>2019-12-07 14:04:35 +0100
commit2cf304056aefd7c5d961703280d9bc1d3535dc4e (patch)
tree5517c858b55978c66e2afbb574c2574be4616b06
parent2db28bc006819eacb8a6cd8d178f82a9fa0d62f1 (diff)
downloadmeta-updater-pr/645/ostree-drop-redundant-patch.tar.gz
ostree: adjust to ostree in meta-openembeddedpr/645/ostree-drop-redundant-patch
Drop a patch that has been merged into meta-openembedded by commit 000448b0: [ ostree: Backport build/test fixes from upstream ] Also move builtin-grub2-mkconfig to PACKAGECONFIG, drop a redundant FILES setting. Signed-off-by: Ming Liu <liu.ming50@gmail.com>
-rw-r--r--recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch60
-rw-r--r--recipes-extended/ostree/ostree_%.bbappend16
2 files changed, 1 insertions, 75 deletions
diff --git a/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch b/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch
deleted file mode 100644
index 1f8a06b..0000000
--- a/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1From de8e0765a4a54f0367999f682ce4cc53bfaa60b0 Mon Sep 17 00:00:00 2001
2From: Ricardo Salveti <ricardo@foundries.io>
3Date: Tue, 5 Nov 2019 21:16:07 -0300
4Subject: [PATCH] Makefile: declare ostree_boot_SCRIPTS and append values
5
6ostree_boot_SCRIPTS was being set on both Makefile-boot.am and
7Makefile-switchroot.am, causing the first one to be replaced by the
8other at the final Makefile, so declare as empty and append on both
9places instead.
10
11Upstream-Status: Backport
12
13Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
14---
15 Makefile-boot.am | 2 +-
16 Makefile-decls.am | 1 +
17 Makefile-switchroot.am | 2 +-
18 3 files changed, 3 insertions(+), 2 deletions(-)
19
20diff --git a/Makefile-boot.am b/Makefile-boot.am
21index b4d4a1af..b51928f0 100644
22--- a/Makefile-boot.am
23+++ b/Makefile-boot.am
24@@ -60,7 +60,7 @@ grub2configdir = $(sysconfdir)/grub.d
25 INSTALL_DATA_HOOKS += install-grub2-config-hook
26 else
27 # We're using our internal generator
28-ostree_boot_SCRIPTS = src/boot/grub2/ostree-grub-generator
29+ostree_boot_SCRIPTS += src/boot/grub2/ostree-grub-generator
30 endif
31
32 EXTRA_DIST += src/boot/dracut/module-setup.sh \
33diff --git a/Makefile-decls.am b/Makefile-decls.am
34index 115c19fb..086ee138 100644
35--- a/Makefile-decls.am
36+++ b/Makefile-decls.am
37@@ -47,6 +47,7 @@ typelibdir = $(libdir)/girepository-1.0
38 typelib_DATA =
39 gsettings_SCHEMAS =
40 ostree_bootdir = $(prefix)/lib/ostree
41+ostree_boot_SCRIPTS =
42 ostree_boot_PROGRAMS =
43
44 # This initializes some more variables
45diff --git a/Makefile-switchroot.am b/Makefile-switchroot.am
46index ff44d4bc..b81b843f 100644
47--- a/Makefile-switchroot.am
48+++ b/Makefile-switchroot.am
49@@ -42,7 +42,7 @@ if BUILDOPT_USE_STATIC_COMPILER
50 # to get autotools to install this as an executable but without generating rules
51 # to make it itself which we have specified manually. See
52 # https://lists.gnu.org/archive/html/help-gnu-utils/2007-01/msg00007.html
53-ostree_boot_SCRIPTS = ostree-prepare-root
54+ostree_boot_SCRIPTS += ostree-prepare-root
55
56 ostree-prepare-root : $(ostree_prepare_root_SOURCES)
57 $(STATIC_COMPILER) -o $@ -static $(top_srcdir)/src/switchroot/ostree-prepare-root.c $(ostree_prepare_root_CPPFLAGS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) -DOSTREE_PREPARE_ROOT_STATIC=1
58--
592.24.0
60
diff --git a/recipes-extended/ostree/ostree_%.bbappend b/recipes-extended/ostree/ostree_%.bbappend
index cf2f24f..fd1795f 100644
--- a/recipes-extended/ostree/ostree_%.bbappend
+++ b/recipes-extended/ostree/ostree_%.bbappend
@@ -1,18 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1PACKAGECONFIG_append = " curl libarchive static builtin-grub2-mkconfig"
2
3SRC_URI += " \
4 file://0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch \
5"
6
7PACKAGECONFIG_append = " curl libarchive static"
8PACKAGECONFIG_class-native_append = " curl" 2PACKAGECONFIG_class-native_append = " curl"
9PACKAGECONFIG_remove = "soup" 3PACKAGECONFIG_remove = "soup"
10PACKAGECONFIG_class-native_remove = "soup" 4PACKAGECONFIG_class-native_remove = "soup"
11
12EXTRA_OECONF += " \
13 --with-builtin-grub2-mkconfig \
14"
15
16FILES_${PN} += " \
17 ${libdir}/ostree/ostree-grub-generator \
18"