summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2019-10-16 16:36:41 +0200
committerLaurent Bonnans <laurent.bonnans@here.com>2019-10-17 15:06:20 +0200
commitec1ac0617b120813d6450dffe1aa8d4868e37332 (patch)
tree25a9d4d3facf0498d62d45675f7d6434d7321052
parent4608e5dd6744b6dfa521c78d04356121ca5d3ab1 (diff)
downloadmeta-updater-fix/use-aktualizr-rls.tar.gz
Fix aktualizr version reporting in yocto imagefix/use-aktualizr-rls
Stop overriding AKTUALIZR_VERSION with the recipe version which is mostly bogus. And bump aktualizr to make sure we're using a version which fails at configure time if no version was specified. Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 0a9b9b0..d878d88 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "SOTA Client application written in C++"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr" 3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base" 4SECTION = "base"
5LICENSE = "MPL-2.0" 5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" 6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
7 7
8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" 8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native"
9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" 9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}"
@@ -30,7 +30,7 @@ SRC_URI = " \
30SRC_URI[garagesign.md5sum] = "66ffe8dcd61d4c15646e1c4b7dde7401" 30SRC_URI[garagesign.md5sum] = "66ffe8dcd61d4c15646e1c4b7dde7401"
31SRC_URI[garagesign.sha256sum] = "7a7193ddf7e1a33ea60fbb20f98318a8bd78c325dab391d8c4ebd644a738abdc" 31SRC_URI[garagesign.sha256sum] = "7a7193ddf7e1a33ea60fbb20f98318a8bd78c325dab391d8c4ebd644a738abdc"
32 32
33SRCREV = "d13ff1ceeca2694b982287740aca8f58edad514d" 33SRCREV = "1592d4ab63d8851aca3440529701425612fbe903"
34BRANCH ?= "master" 34BRANCH ?= "master"
35 35
36S = "${WORKDIR}/git" 36S = "${WORKDIR}/git"
@@ -45,7 +45,7 @@ SYSTEMD_PACKAGES = "${PN} ${PN}-secondary"
45SYSTEMD_SERVICE_${PN} = "aktualizr.service" 45SYSTEMD_SERVICE_${PN} = "aktualizr.service"
46SYSTEMD_SERVICE_${PN}-secondary = "aktualizr-secondary.service" 46SYSTEMD_SERVICE_${PN}-secondary = "aktualizr-secondary.service"
47 47
48EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DAKTUALIZR_VERSION=${PV} ${@bb.utils.contains('PTEST_ENABLED', '1', '-DTESTSUITE_VALGRIND=on', '', d)}" 48EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release ${@bb.utils.contains('PTEST_ENABLED', '1', '-DTESTSUITE_VALGRIND=on', '', d)}"
49 49
50GARAGE_SIGN_OPS = "${@ d.expand('-DGARAGE_SIGN_ARCHIVE=${WORKDIR}/cli-${GARAGE_SIGN_PV}.tgz') if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''}" 50GARAGE_SIGN_OPS = "${@ d.expand('-DGARAGE_SIGN_ARCHIVE=${WORKDIR}/cli-${GARAGE_SIGN_PV}.tgz') if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''}"
51 51
@@ -69,8 +69,12 @@ RESOURCE_CPU_WEIGHT = "100"
69RESOURCE_MEMORY_HIGH = "100M" 69RESOURCE_MEMORY_HIGH = "100M"
70RESOURCE_MEMORY_MAX = "80%" 70RESOURCE_MEMORY_MAX = "80%"
71 71
72do_compile_ptest() { 72do_configure_prepend() {
73 cmake_runcmake_build --target build_tests "${PARALLEL_MAKE}" 73 # CMake has trouble finding yocto's git when cross-compiling, let's do this step manually
74 cd ${S}
75 if [ ! -f VERSION ]; then
76 ./scripts/get_version.sh > VERSION
77 fi
74} 78}
75 79
76do_install_ptest() { 80do_install_ptest() {