summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Bonnans <laurent.bonnans@here.com>2018-03-28 19:04:14 +0200
committerLaurent Bonnans <laurent.bonnans@here.com>2018-03-28 22:29:02 +0200
commit88bb0d56833d1f8ce4b9768cf5af53209750a5dd (patch)
tree80daf5a0d366ea75963f45cd3c70886f067f135e
parentbca6c0b09593c77d9ac78caae2f7488adb1d90f4 (diff)
downloadmeta-updater-fix/primary-image-nowait.tar.gz
Do not wait for qemu network bridge to come up on primaryfix/primary-image-nowait
It is incorrectly kept in the "Configuring" state by systemd-networkd
-rw-r--r--recipes-test/demo-network-config/files/systemd-networkd-wait-online.service.override3
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb10
2 files changed, 11 insertions, 2 deletions
diff --git a/recipes-test/demo-network-config/files/systemd-networkd-wait-online.service.override b/recipes-test/demo-network-config/files/systemd-networkd-wait-online.service.override
new file mode 100644
index 0000000..1dec20c
--- /dev/null
+++ b/recipes-test/demo-network-config/files/systemd-networkd-wait-online.service.override
@@ -0,0 +1,3 @@
1[Service]
2ExecStart=
3ExecStart=/lib/systemd/systemd-networkd-wait-online --ignore=enp0s4
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 78678a2..742acb4 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -3,14 +3,20 @@ LICENSE = "CLOSED"
3 3
4inherit allarch 4inherit allarch
5 5
6SRC_URI = "file://25-dhcp-server.network" 6SRC_URI = "file://25-dhcp-server.network \
7 file://systemd-networkd-wait-online.service.override \
8 "
7 9
8 10
9FILES_${PN} = "/usr/lib/systemd/network" 11FILES_${PN} = "/usr/lib/systemd/network \
12 /usr/lib/systemd/system/systemd-networkd-wait-online.service.d \
13 "
10 14
11PR = "1" 15PR = "1"
12 16
13do_install() { 17do_install() {
14 install -d ${D}/usr/lib/systemd/network 18 install -d ${D}/usr/lib/systemd/network
15 install -m 0644 ${WORKDIR}/25-dhcp-server.network ${D}/usr/lib/systemd/network/ 19 install -m 0644 ${WORKDIR}/25-dhcp-server.network ${D}/usr/lib/systemd/network/
20 install -d ${D}/usr/lib/systemd/system/systemd-networkd-wait-online.service.d
21 install -m 0644 ${WORKDIR}/systemd-networkd-wait-online.service.override ${D}/usr/lib/systemd/system/systemd-networkd-wait-online.service.d/override.conf
16} 22}