summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-10-21 10:11:04 +0200
committerAnatoliy Odukha <aodukha@gmail.com>2020-10-30 15:56:21 +0200
commit151a50cfc5e5656f18ec38e06771805b28c290c2 (patch)
treee57fdfc299fae1fe0c1a56e75f4420058e7859a5
parent51c1de297da39e4517e5d81e68a96e65da425173 (diff)
downloadmeta-updater-feat/warrior/2020.10.tar.gz
aktualizr: Don't put unused configs in the image.feat/warrior/2020.10
Because every aktualizr package was depending on aktualizr-configs, all of the default configs were getting installed to /usr/lib/sota, despite that by default none of them were ever used on the device. That dependency has been removed. The provisioning recipes still install the recipes they need to the default location that aktualizr actually uses (/usr/lib/sota/conf.d). If you want to use anything else, a specific recipe should be created to do so. This change rendered the aktualizr-host-tools package useless, so it has been removed. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb2
-rw-r--r--recipes-sota/aktualizr/aktualizr-device-prov.bb2
-rw-r--r--recipes-sota/aktualizr/aktualizr-shared-prov.bb2
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb9
4 files changed, 6 insertions, 9 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
index 8f28c03..7239bfd 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
7 7
8inherit allarch 8inherit allarch
9 9
10# We need to get the config files from the aktualizr-host-tools package built by 10# We need to get the config files from the aktualizr-configs package built by
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13 13
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb
index 55f398d..391b098 100644
--- a/recipes-sota/aktualizr/aktualizr-device-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
7 7
8inherit allarch 8inherit allarch
9 9
10# We need to get the config files from the aktualizr-host-tools package built by 10# We need to get the config files from the aktualizr-configs package built by
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13 13
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/recipes-sota/aktualizr/aktualizr-shared-prov.bb
index 0f712df..0c54f32 100644
--- a/recipes-sota/aktualizr/aktualizr-shared-prov.bb
+++ b/recipes-sota/aktualizr/aktualizr-shared-prov.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
7 7
8inherit allarch 8inherit allarch
9 9
10# We need to get the config files from the aktualizr-host-tools package built by 10# We need to get the config files from the aktualizr-configs package built by
11# the aktualizr (target) recipe. 11# the aktualizr (target) recipe.
12DEPENDS = "aktualizr" 12DEPENDS = "aktualizr"
13RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}" 13RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}"
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 4802a9e..c09e7cb 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -7,8 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
7 7
8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" 8DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native"
9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" 9DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}"
10RDEPENDS_${PN}_class-target = "${PN}-configs ${PN}-hwid lshw" 10RDEPENDS_${PN}_class-target = "${PN}-hwid lshw"
11RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}"
12 11
13RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" 12RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind"
14 13
@@ -133,14 +132,12 @@ python split_hosttools_packages () {
133 bindir = d.getVar('bindir') 132 bindir = d.getVar('bindir')
134 133
135 # Split all binaries to their own packages. 134 # Split all binaries to their own packages.
136 do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) 135 do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='', prepend=False)
137} 136}
138 137
139PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" 138PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*"
140 139
141PACKAGES =+ "${PN}-host-tools ${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" 140PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib"
142
143ALLOW_EMPTY_${PN}-host-tools = "1"
144 141
145FILES_${PN} = " \ 142FILES_${PN} = " \
146 ${bindir}/aktualizr \ 143 ${bindir}/aktualizr \