summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMykhaylo Sul <ext-mykhaylo.sul@here.com>2020-01-03 11:36:09 +0100
committerMykhaylo Sul <ext-mykhaylo.sul@here.com>2020-01-17 16:02:22 +0200
commit6e1732f529f4863edfc34a7944d7614c8843e110 (patch)
treeecb0968750b1f4cc175368090e3a6b18d499550a
parent3df17b1bd8c6c9b6ed5a82e6f30bb2f485ad9015 (diff)
downloadmeta-updater-feat/OTA-4174/ostree-update-default-on-secondary.tar.gz
OTA-4174: Make an ostree update a default on IP Secondaryfeat/OTA-4174/ostree-update-default-on-secondary
Signed-off-by: Mykhaylo Sul <ext-mykhaylo.sul@here.com>
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb2
-rw-r--r--recipes-test/demo-config/files/30-fake-pacman.toml2
-rw-r--r--recipes-test/demo-config/files/30-ostree-pacman.toml2
-rw-r--r--recipes-test/demo-config/secondary-config.bb6
4 files changed, 6 insertions, 6 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index 2e91a7b..5728830 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -30,7 +30,7 @@ SRC_URI = " \
30SRC_URI[garagesign.md5sum] = "3e1ae6d49cc66fda37cef47f849d9609" 30SRC_URI[garagesign.md5sum] = "3e1ae6d49cc66fda37cef47f849d9609"
31SRC_URI[garagesign.sha256sum] = "8d49b83efa222db2f092ee14348459ee1bfd048552b57c3cb5ab48db8e347d82" 31SRC_URI[garagesign.sha256sum] = "8d49b83efa222db2f092ee14348459ee1bfd048552b57c3cb5ab48db8e347d82"
32 32
33SRCREV = "bc54d32b8d4e97409908e700b9615fef2ca7ced2" 33SRCREV = "14f7c6e74e8fade755dfdd03c856865127ba12b6"
34BRANCH ?= "master" 34BRANCH ?= "master"
35 35
36S = "${WORKDIR}/git" 36S = "${WORKDIR}/git"
diff --git a/recipes-test/demo-config/files/30-fake-pacman.toml b/recipes-test/demo-config/files/30-fake-pacman.toml
deleted file mode 100644
index 3fb5cf2..0000000
--- a/recipes-test/demo-config/files/30-fake-pacman.toml
+++ /dev/null
@@ -1,2 +0,0 @@
1[pacman]
2type = "fake"
diff --git a/recipes-test/demo-config/files/30-ostree-pacman.toml b/recipes-test/demo-config/files/30-ostree-pacman.toml
new file mode 100644
index 0000000..d2cf5b8
--- /dev/null
+++ b/recipes-test/demo-config/files/30-ostree-pacman.toml
@@ -0,0 +1,2 @@
1[pacman]
2type = "ostree"
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb
index ddbed89..58b18df 100644
--- a/recipes-test/demo-config/secondary-config.bb
+++ b/recipes-test/demo-config/secondary-config.bb
@@ -12,14 +12,14 @@ SOTA_HARDWARE_ID ?= "${MACHINE}-sndry"
12SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" 12SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}"
13 13
14SRC_URI = "\ 14SRC_URI = "\
15 file://30-fake-pacman.toml \ 15 file://30-ostree-pacman.toml \
16 file://35-network-config.toml \ 16 file://35-network-config.toml \
17 file://45-id-config.toml \ 17 file://45-id-config.toml \
18 " 18 "
19 19
20do_install () { 20do_install () {
21 install -m 0700 -d ${D}${libdir}/sota/conf.d 21 install -m 0700 -d ${D}${libdir}/sota/conf.d
22 install -m 0644 ${WORKDIR}/30-fake-pacman.toml ${D}${libdir}/sota/conf.d/30-fake-pacman.toml 22 install -m 0644 ${WORKDIR}/30-ostree-pacman.toml ${D}${libdir}/sota/conf.d/30-ostree-pacman.toml
23 23
24 install -m 0644 ${WORKDIR}/35-network-config.toml ${D}${libdir}/sota/conf.d/35-network-config.toml 24 install -m 0644 ${WORKDIR}/35-network-config.toml ${D}${libdir}/sota/conf.d/35-network-config.toml
25 sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \ 25 sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \
@@ -36,7 +36,7 @@ do_install () {
36 36
37FILES_${PN} = " \ 37FILES_${PN} = " \
38 ${libdir}/sota/conf.d \ 38 ${libdir}/sota/conf.d \
39 ${libdir}/sota/conf.d/30-fake-pacman.toml \ 39 ${libdir}/sota/conf.d/30-ostree-pacman.toml \
40 ${libdir}/sota/conf.d/35-network-config.toml \ 40 ${libdir}/sota/conf.d/35-network-config.toml \
41 ${libdir}/sota/conf.d/45-id-config.toml \ 41 ${libdir}/sota/conf.d/45-id-config.toml \
42 " 42 "