summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sul <ext-mykhaylo.sul@here.com>2019-06-18 10:11:18 +0300
committerMike Sul <ext-mykhaylo.sul@here.com>2019-06-18 10:11:18 +0300
commitfcf3daa7d63bf9a9948bafb2cc0472dc7d08d401 (patch)
treebc1a06637008e9430c42164916bcedb0294809a5
parent99e8cb86f6b7d02c618bbb492e776d24d22821e4 (diff)
downloadmeta-updater-feat/OTA-2294/preconfigured-secondaries-on-RPi.tar.gz
OTA-2294: Use WiFi on Primary (if enabled) to communicate with the backend in case of RPi targetfeat/OTA-2294/preconfigured-secondaries-on-RPi
Signed-off-by: Mike Sul <ext-mykhaylo.sul@here.com>
-rw-r--r--conf/include/bblayers/sota_raspberrypi3.inc1
-rw-r--r--recipes-test/demo-network-config/network-config.inc2
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb3
-rw-r--r--recipes-test/demo-network-config/secondary-network-config.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/conf/include/bblayers/sota_raspberrypi3.inc b/conf/include/bblayers/sota_raspberrypi3.inc
index ea420ba..7e320af 100644
--- a/conf/include/bblayers/sota_raspberrypi3.inc
+++ b/conf/include/bblayers/sota_raspberrypi3.inc
@@ -1,2 +1,3 @@
1BBLAYERS += "${METADIR}/meta-updater-raspberrypi" 1BBLAYERS += "${METADIR}/meta-updater-raspberrypi"
2BBLAYERS += "${METADIR}/meta-raspberrypi" 2BBLAYERS += "${METADIR}/meta-raspberrypi"
3BBLAYERS += "${METADIR}/meta-openembedded/meta-networking"
diff --git a/recipes-test/demo-network-config/network-config.inc b/recipes-test/demo-network-config/network-config.inc
index c713589..ed623d4 100644
--- a/recipes-test/demo-network-config/network-config.inc
+++ b/recipes-test/demo-network-config/network-config.inc
@@ -1,5 +1,3 @@
1CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('IMAGE_TYPE') == 'primary' else 'static'}"
2
3SRC_URI_append = "\ 1SRC_URI_append = "\
4 file://26-${CONF_TYPE}-client.network \ 2 file://26-${CONF_TYPE}-client.network \
5 " 3 "
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 1c17e0a..d840a95 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -18,8 +18,9 @@ do_install() {
18} 18}
19 19
20PRIMARY_IP ?= "10.0.3.1" 20PRIMARY_IP ?= "10.0.3.1"
21
21IP_ADDR = "${PRIMARY_IP}" 22IP_ADDR = "${PRIMARY_IP}"
22IMAGE_TYPE = "primary" 23CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"
23 24
24require network-config.inc 25require network-config.inc
25 26
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb
index 1c7f01c..b1d70f1 100644
--- a/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/recipes-test/demo-network-config/secondary-network-config.bb
@@ -23,7 +23,7 @@ do_install() {
23 23
24SECONDARY_IP ?= "10.0.3.2" 24SECONDARY_IP ?= "10.0.3.2"
25IP_ADDR = "${SECONDARY_IP}" 25IP_ADDR = "${SECONDARY_IP}"
26IMAGE_TYPE = "secondary" 26CONF_TYPE = "static"
27 27
28require network-config.inc 28require network-config.inc
29 29