summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2018-11-16 17:35:39 +0100
committerPatrick Vacek <patrickvacek@gmail.com>2018-11-16 17:37:46 +0100
commit433b40e6fee7db4f3ff675ce5361c02a8f24ac49 (patch)
tree677310579787e37d866cd9722195dd93409cc7be
parentf799da5e7a73a740f33fa40087b9799e10ac8d7c (diff)
downloadmeta-updater-doc/oe-selftest-and-rm-example.tar.gz
docs: better explanation of oe-selftest requirements.doc/oe-selftest-and-rm-example
Also remove all references to aktualizr-example-interface. It has been removed. Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
-rw-r--r--CONTRIBUTING.adoc2
-rw-r--r--README.adoc3
-rwxr-xr-xscripts/find_aktualizr_dependencies.sh5
3 files changed, 5 insertions, 5 deletions
diff --git a/CONTRIBUTING.adoc b/CONTRIBUTING.adoc
index f12b95d..4d9e8f6 100644
--- a/CONTRIBUTING.adoc
+++ b/CONTRIBUTING.adoc
@@ -17,7 +17,7 @@ If you are developing with meta-updater, it may be helpful to read the README an
17 17
18* OTA-enabled build succeeds for at least one platform, the resulting image boots, and an update can be installed. This check is absolutely necessary for every pull request unless it only touches documentation. 18* OTA-enabled build succeeds for at least one platform, the resulting image boots, and an update can be installed. This check is absolutely necessary for every pull request unless it only touches documentation.
19* If your change touches platform code (like `classes/sota_<platform>.bbclass`), please check building and updating on this particular platform. 19* If your change touches platform code (like `classes/sota_<platform>.bbclass`), please check building and updating on this particular platform.
20* oe-selftest succeeds. To test meta-updater, run `oe-selftest -r updater` from a build directory with `MACHINE` set to `qemux86-64`. 20* oe-selftest succeeds. To test meta-updater, run `oe-selftest -r updater` from a build directory with `MACHINE` set to `qemux86-64`. See the link:README.adoc#qa-with-oe-selftest[relevant section of the README] for more details.
21* Updates are forwards- and backwards-compatible. You should be able to update an OTA-enabled build before the change is applied to the version with change applied and vice versa. One should pay double attention to the compatibility when bootloader code is affected. 21* Updates are forwards- and backwards-compatible. You should be able to update an OTA-enabled build before the change is applied to the version with change applied and vice versa. One should pay double attention to the compatibility when bootloader code is affected.
22* The patch/branch should be based on the latest version of the target branch. This may mean that rebasing is necessary if other PRs are merged before yours is approved. 22* The patch/branch should be based on the latest version of the target branch. This may mean that rebasing is necessary if other PRs are merged before yours is approved.
23 23
diff --git a/README.adoc b/README.adoc
index 6424a28..bed0591 100644
--- a/README.adoc
+++ b/README.adoc
@@ -146,7 +146,6 @@ First, you can set `SOTA_CLIENT_PROV` to control which provisioning recipe is us
146 146
147Second, you can write recipes to install additional config files with customized options. A few recipes already exist to address common needs and provide an example: 147Second, you can write recipes to install additional config files with customized options. A few recipes already exist to address common needs and provide an example:
148 148
149* link:recipes-sota/config/aktualizr-example-interface.bb[aktualizr-example-interface.bb] will configure aktualizr to connect to an example interface for a legacy flasher. This is intended to be used in conjunction with the `aktualizr-examples` package. See https://github.com/advancedtelematic/aktualizr/blob/master/docs/legacysecondary.adoc[legacysecondary.adoc] in the aktualizr repo for more information.
150* link:recipes-sota/config/aktualizr-disable-send-ip.bb[aktualizr-disable-send-ip.bb] disables the reporting of networking information to the server. This is enabled by default and supported by https://connect.ota.here.com/[HERE OTA Connect]. However, if you are using a different server that does not support this feature, you may want to disable it in aktualizr. 149* link:recipes-sota/config/aktualizr-disable-send-ip.bb[aktualizr-disable-send-ip.bb] disables the reporting of networking information to the server. This is enabled by default and supported by https://connect.ota.here.com/[HERE OTA Connect]. However, if you are using a different server that does not support this feature, you may want to disable it in aktualizr.
151* link:recipes-sota/config/aktualizr-log-debug.bb[aktualizr-log-debug.bb] sets the log level of aktualizr to 0 (trace). The default is 2 (info). This recipe is intended for development and debugging purposes. 150* link:recipes-sota/config/aktualizr-log-debug.bb[aktualizr-log-debug.bb] sets the log level of aktualizr to 0 (trace). The default is 2 (info). This recipe is intended for development and debugging purposes.
152 151
@@ -181,7 +180,7 @@ Please note that [target name, target version] pairs are expected to be unique i
181 180
182== QA with oe-selftest 181== QA with oe-selftest
183 182
184This layer relies on the test framework oe-selftest for quality assurance. Follow the steps below to run the tests: 183This layer relies on the test framework oe-selftest for quality assurance. Currently, you will need to run this in a build directory with `MACHINE` set to `qemux86-64`. Follow the steps below to run the tests:
185 184
1861. Append the line below to `conf/local.conf` to disable the warning about supported operating systems: 1851. Append the line below to `conf/local.conf` to disable the warning about supported operating systems:
187+ 186+
diff --git a/scripts/find_aktualizr_dependencies.sh b/scripts/find_aktualizr_dependencies.sh
index 786d8a9..986b541 100755
--- a/scripts/find_aktualizr_dependencies.sh
+++ b/scripts/find_aktualizr_dependencies.sh
@@ -11,11 +11,12 @@ parentdir="$(dirname "$0")"
11# those are common dependencies not enabled by default. 11# those are common dependencies not enabled by default.
12${parentdir}/find_dependencies.py aktualizr 12${parentdir}/find_dependencies.py aktualizr
13${parentdir}/find_dependencies.py aktualizr-auto-prov 13${parentdir}/find_dependencies.py aktualizr-auto-prov
14${parentdir}/find_dependencies.py aktualizr-implicit-prov 14${parentdir}/find_dependencies.py aktualizr-auto-prov-creds
15${parentdir}/find_dependencies.py aktualizr-ca-implicit-prov 15${parentdir}/find_dependencies.py aktualizr-ca-implicit-prov
16${parentdir}/find_dependencies.py aktualizr-ca-implicit-prov-creds
16${parentdir}/find_dependencies.py aktualizr-hsm-prov 17${parentdir}/find_dependencies.py aktualizr-hsm-prov
18${parentdir}/find_dependencies.py aktualizr-hsm-prov-creds
17${parentdir}/find_dependencies.py aktualizr-disable-send-ip 19${parentdir}/find_dependencies.py aktualizr-disable-send-ip
18${parentdir}/find_dependencies.py aktualizr-example-interface
19${parentdir}/find_dependencies.py aktualizr-log-debug 20${parentdir}/find_dependencies.py aktualizr-log-debug
20${parentdir}/find_dependencies.py libp11 21${parentdir}/find_dependencies.py libp11
21${parentdir}/find_dependencies.py dpkg 22${parentdir}/find_dependencies.py dpkg