summaryrefslogtreecommitdiffstats
path: root/recipes-ti/multiprocmgr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/multiprocmgr')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb44
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb31
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr.inc21
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service14
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb44
5 files changed, 0 insertions, 154 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
deleted file mode 100644
index 41efe38b..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY = "TI Multiproc Manager (RTOS) for KeyStone II"
2DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
3
4require recipes-ti/includes/ti-paths.inc
5require recipes-ti/multiprocmgr/multiprocmgr.inc
6
7DEPENDS = "ti-cgt6x-native"
8
9PR = "${INC_PR}.2"
10
11PACKAGES =+ "${PN}-test"
12FILES:${PN}-test = "${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
13 ${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/*.out"
14
15EXTRA_OEMAKE = "LOCAL_SYSROOT="${STAGING_DIR_TARGET}" \
16 C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
17 "
18
19do_compile() {
20 oe_runmake c66x
21 oe_runmake test_c66x
22}
23
24do_install() {
25 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
26 install -d ${D}${MPM_INSTALL_DIR_RECIPE}
27 cp ${CP_ARGS} ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE}
28
29 # Copy C66x binaries
30 install -d ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin
31 cp ${S}/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
32 ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/
33 install -d ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin
34 cp ${S}/test/sync_test/c66x/bin/*.out \
35 ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/
36}
37
38FILES:${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}"
39INSANE_SKIP:${PN}-dev = "arch"
40INSANE_SKIP:${PN}-test = "arch"
41
42RDEPENDS:${PN}-dev = "bash"
43
44ALLOW_EMPTY:${PN} = "1"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
deleted file mode 100644
index 3d1b3aee..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "TI Multiproc Manager test code"
2
3include multiprocmgr.inc
4
5PR = "${INC_PR}.2"
6
7DEPENDS = "multiprocmgr cmem"
8RDEPENDS:${PN} = "multiprocmgr mpm-transport cmem"
9RDEPENDS:${PN} += "multiprocmgr-rtos-test bash"
10
11FILES:${PN} += "\
12 ${datadir}/ti/examples/mpm \
13"
14
15FILES:${PN}-dbg += "\
16 ${datadir}/ti/examples/mpm/*/.debug \
17"
18
19do_compile() {
20 oe_runmake -C ${S} test
21}
22
23do_install() {
24 # Copy Sources and binary
25 install -d ${D}${datadir}/ti/examples/mpm/src
26 cp -r ${S}/src/mailbox ${D}${datadir}/ti/examples/mpm/src
27 cp -r ${S}/src/sync ${D}${datadir}/ti/examples/mpm/src
28 cp -r ${S}/test ${D}${datadir}/ti/examples/mpm
29}
30
31INSANE_SKIP:${PN} = "ldflags staticdev"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr.inc b/recipes-ti/multiprocmgr/multiprocmgr.inc
deleted file mode 100644
index 64fb6f6f..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/multi-proc-manager.git"
2LICENSE = "BSD-3-Clause & MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4"
4SECTION = "console"
5COMPATIBLE_MACHINE = "keystone"
6
7MULTIPROCMGR_GIT_URI = "git://git.ti.com/keystone-linux/multi-proc-manager.git"
8MULTIPROCMGR_GIT_PROTOCOL = "git"
9MULTIPROCMGR_GIT_BRANCH = "master"
10
11# The following commits correspond to DEV.MPM-3.00.05.00
12MULTIPROCMGR_SRCREV = "810d8a31c797d07abe808cb3fa89465fa934d4dd"
13
14PV = "3.0.5.0"
15INC_PR = "r1"
16
17BRANCH = "${MULTIPROCMGR_GIT_BRANCH}"
18SRC_URI = "${MULTIPROCMGR_GIT_URI};protocol=${MULTIPROCMGR_GIT_PROTOCOL};branch=${BRANCH}"
19SRCREV = "${MULTIPROCMGR_SRCREV}"
20
21S = "${WORKDIR}/git"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service b/recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service
deleted file mode 100644
index 40eb4650..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service
+++ /dev/null
@@ -1,14 +0,0 @@
1[Unit]
2Description=TI Multiproc Manager
3
4[Service]
5ExecStartPre=/sbin/modprobe keystone_remoteproc
6ExecStartPre=/sbin/modprobe keystone_dsp_mem
7ExecStartPre=/sbin/modprobe uio_module_drv
8
9Type=forking
10PIDFile=/var/run/mpm/pid
11ExecStart=/usr/bin/mpmsrv
12
13[Install]
14WantedBy=basic.target
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
deleted file mode 100644
index 1bd24885..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY = "TI Multiproc Manager for KeyStone II"
2DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
3
4include multiprocmgr.inc
5
6SRC_URI += " \
7 file://mpmsrv-daemon.service \
8"
9
10PR = "${INC_PR}.2"
11
12DEPENDS = "mpm-transport libdaemon virtual/kernel cmem"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16INITSCRIPT_NAME = "mpmsrv-daemon.sh"
17INITSCRIPT_PARAMS = "defaults 10"
18
19SYSTEMD_SERVICE:${PN} = "mpmsrv-daemon.service"
20
21inherit update-rc.d systemd
22
23do_install() {
24 install -d ${D}${bindir}/
25 install -c -m 755 ${S}/bin/mpmsrv ${D}${bindir}/mpmsrv
26 install -c -m 755 ${S}/bin/mpmcl ${D}${bindir}/mpmcl
27
28 install -d ${D}${systemd_system_unitdir}
29 install -m 0644 ${WORKDIR}/mpmsrv-daemon.service ${D}${systemd_system_unitdir}
30 install -d ${D}${sysconfdir}/init.d/
31 install -c -m 755 ${S}/scripts/mpmsrv-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
32
33 install -d ${D}${sysconfdir}/mpm/
34 install -c -m 755 ${S}/scripts/crash_callback.sh ${D}${sysconfdir}/mpm/crash_callback.sh
35
36 install -d ${D}${includedir}/
37 install -c -m 755 ${S}/include/* ${D}${includedir}/
38
39 install -d ${D}${libdir}/
40 cp -a ${S}/lib/* ${D}${libdir}/
41 chown -R root:root ${D}${libdir}/
42}
43
44INSANE_SKIP:${PN} = "ldflags"