summaryrefslogtreecommitdiffstats
path: root/recipes-ti/codec-engine/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/codec-engine/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch')
-rw-r--r--recipes-ti/codec-engine/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-ti/codec-engine/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch b/recipes-ti/codec-engine/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch
new file mode 100644
index 00000000..8e47ae21
--- /dev/null
+++ b/recipes-ti/codec-engine/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch
@@ -0,0 +1,26 @@
1From 58c50064afdc2fd7093613e0ae3a9192ea189460 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 5 Jan 2011 10:10:33 +0100
4Subject: [PATCH] soc/app: fix makefile to pass -Wl,-T, before the linkerscript
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 soc/app/Makefile | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/soc/app/Makefile b/soc/app/Makefile
12index 0bb7bdc..342e43a 100755
13--- a/soc/app/Makefile
14+++ b/soc/app/Makefile
15@@ -33,7 +33,7 @@ XDC_CFG = $(TARGET)_config
16 XDC_CFLAGS = $(XDC_CFG)/compiler.opt
17
18 # Output linker file
19-XDC_LFILE = $(XDC_CFG)/linker.cmd
20+XDC_LFILE = -Wl,-T,$(XDC_CFG)/linker.cmd
21
22 # Input configuration file
23 XDC_CFGFILE = $(PLATFORM)/$(TARGET).cfg
24--
251.6.6.1
26