summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot_2012.04.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_2012.04.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.04.01.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2012.04.01.bb b/recipes-bsp/u-boot/u-boot_2012.04.01.bb
new file mode 100644
index 00000000..6cc63ed0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2012.04.01.bb
@@ -0,0 +1,50 @@
1# Use the version of u-boot.inc in oe-core not the meta-ti version
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4DESCRIPTION = "u-boot bootloader for ARM MPU devices"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
8
9DEFAULT_PREFERENCE = "-1"
10
11COMPATIBLE_MACHINE = "am37x-evm|beagleboard"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15BRANCH ?= "master"
16
17SRCREV = "v2012.04.01"
18
19S = "${WORKDIR}/git"
20
21SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
22
23# Add patches for the AMSDK
24# - 0001-omap3-beagle-add-usbethaddr....Not for Upstream
25# - 0001-OMAP3-Beagle-Set-BOOTDELAY....Pending Upstream
26# - 0002-am335x-am3517evm-beagleboard....Pending Upstream
27# - 0003-beagleboard-Load-uImage-from....Not for Upstream
28# - 0004-beagleboard-Load-uImage-to....Pending Upstream
29# - 0001-omap3_evm-Added-function....Pending Upstream
30# - 0002-omap3evm-Make-the-board....Pending Upstream
31# - 0003-beagleboard-Make-xM-rev....Pending Upstream
32# - 0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch....Upstreamed
33
34# Add a patch to set a default usbethaddr address to enable the out of box
35# experience.
36SRC_URI += "file://0001-omap3_beagle-add-usbethaddr-setting-to-enable-networ.patch \
37 file://0001-OMAP3-Beagle-Set-BOOTDELAY-to-3.patch \
38 file://0002-am335x-am3517evm-beagleboard-am37x-Add-CONFIG_CMD_AS.patch \
39 file://0003-beagleboard-Load-uImage-from-VFAT-by-default.patch \
40 file://0004-beagleboard-Load-uImage-to-the-default-kernel-linux-.patch \
41 file://0001-omap3_evm-Added-function-calls-to-set-volts-speed-on.patch \
42 file://0002-omap3evm-Make-the-board-start-at-800MHz.patch \
43 file://0003-beagleboard-Make-xM-rev-C-go-to-800MHz.patch \
44 file://0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch \
45 "
46
47UBOOT_SUFFIX = "img"
48
49# Set the name of the SPL that will built so that it is also packaged with u-boot.
50SPL_BINARY = "MLO"