summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pm-lld/pm-lld-rtos_git.bb')
-rw-r--r--recipes-bsp/pm-lld/pm-lld-rtos_git.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/recipes-bsp/pm-lld/pm-lld-rtos_git.bb b/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
deleted file mode 100644
index fd01c8ef..00000000
--- a/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "TI RTOS driver for Power Management module (PM)"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://Power.h;beginline=1;endline=31;md5=527b91fdcd26cd19ac07a754f45dedbe"
7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g|k3"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11
12PM_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pm-lld.git"
13PM_LLD_GIT_PROTOCOL = "git"
14
15PM_LLD_GIT_BRANCH = "master"
16
17PM_LLD_GIT_BRANCH:ti33x = "int_pm_am335x"
18PM_LLD_GIT_BRANCH:ti43x = "int_pm_am335x"
19PM_LLD_GIT_BRANCH:k2g = "int_pm_am335x"
20
21PM_LLD_GIT_DESTSUFFIX = "git/ti/drv/pm"
22
23# Below commit ID corresponds to "DEV.PM_LLD.01.08.00.23A"
24PM_LLD_SRCREV = "59abc6ffb890d24b82de0248d204ad10c1bfc2af"
25
26# Below commit ID corresponds to "DEV.PM_LLD.01.04.00.05C"
27PM_LLD_SRCREV:ti33x = "dd1f8486e7738956631b7f4829c8238be2e49dd6"
28PM_LLD_SRCREV:ti43x = "dd1f8486e7738956631b7f4829c8238be2e49dd6"
29PM_LLD_SRCREV:k2g = "dd1f8486e7738956631b7f4829c8238be2e49dd6"
30
31BRANCH = "${PM_LLD_GIT_BRANCH}"
32SRC_URI = "${PM_LLD_GIT_URI};destsuffix=${PM_LLD_GIT_DESTSUFFIX};protocol=${PM_LLD_GIT_PROTOCOL};branch=${BRANCH}"
33
34SRCREV = "${PM_LLD_SRCREV}"
35PV = "01.08.00.23A"
36PR = "r0"
37
38S = "${WORKDIR}/${PM_LLD_GIT_DESTSUFFIX}"
39
40DEPENDS:append = " ti-sysbios \
41 osal-rtos \
42"
43DEPENDS:append:ti33x = " starterware-rtos \
44"
45DEPENDS:append:ti43x = " starterware-rtos \
46"
47
48DEPENDS:append:k3 = " sciclient-rtos \
49"
50
51export PDK_PM_ROOT_PATH = "${WORKDIR}/build"
52export DEST_ROOT="${S}"
53
54# Build with make instead of XDC
55TI_PDK_XDCMAKE = "0"
56
57do_compile:append() {
58 # Delete archive created by XDC release command since it does not contain all content
59 find -name "*.tar" -exec rm -f {} \;
60
61 # Archive from build/ to capture ti/drv/pm/ in archive
62 cd ${B}
63 tar -cf pm_lld.tar --exclude='*.tar' ./*
64}
65
66
67# Workaround: dra7xx build requires am57xx pm libraries for opencl-monitor
68TI_PDK_LIMIT_SOCS:append:dra7xx = " am571x am572x am574x"
69TI_PDK_LIMIT_BOARDS:append:dra7xx = " evmAM571x evmAM572x idkAM574x"
70
71INSANE_SKIP:${PN} = "arch staticdev"