summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pa-lld/pa-lld-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pa-lld/pa-lld-test_git.bb')
-rw-r--r--recipes-bsp/pa-lld/pa-lld-test_git.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld-test_git.bb b/recipes-bsp/pa-lld/pa-lld-test_git.bb
deleted file mode 100644
index 760f1882..00000000
--- a/recipes-bsp/pa-lld/pa-lld-test_git.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "TI PA LLD unit test and example binaries"
2
3DEPENDS = "common-csl-ip pa-lld cppi-lld qmss-lld sa-lld"
4
5include pa-lld.inc
6
7PR = "${INC_PR}.1"
8
9CHOICELIST = "yes no"
10
11CC += "-fcommon"
12
13do_compile () {
14# Now build the lld unit test examples
15 for device in ${DEVICELIST}
16 do
17 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S}
18 for choice in ${CHOICELIST}
19 do
20 make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
21 done
22 done
23}
24
25do_install () {
26 for device in ${DEVICELIST}
27 do
28 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
29 done
30}