summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb')
-rw-r--r--recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb b/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb
new file mode 100644
index 00000000..777c221c
--- /dev/null
+++ b/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Firmware for DSP for an example application called copycodectest"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://DSPDCE-${PV}-Manifest.doc;md5=386d1802eefc2fcf00ab01a5b4556277"
4
5COMPATIBLE_MACHINE = "dra7xx-evm"
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/dspdce/1_00_00_05/exports/dspdce-${MACHINE}-1.00.00.05.tar.gz;protocol=ftp"
9
10S = "${WORKDIR}/dspdce-${MACHINE}-${PV}"
11
12SRC_URI[md5sum] = "4f3d5c6ef088019aa4804eaaedc8e949"
13SRC_URI[sha256sum] = "8d99c4f149613448a6d72c62a18cc7445c63c687b786658da1762c4e1c03a6a0"
14
15TARGET = "dra7-dsp1-fw.xe66"
16
17do_install() {
18 mkdir -p ${D}${base_libdir}/firmware
19 cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
20}
21
22FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
23
24INSANE_SKIP_${PN} = "arch"
25
26PR = "r1"