summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/dfe-lld/dfe-lld_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/dfe-lld/dfe-lld_git.bb')
-rw-r--r--recipes-bsp/dfe-lld/dfe-lld_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/dfe-lld/dfe-lld_git.bb b/recipes-bsp/dfe-lld/dfe-lld_git.bb
new file mode 100644
index 00000000..a2477ca6
--- /dev/null
+++ b/recipes-bsp/dfe-lld/dfe-lld_git.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "Digital Radio Front End low level driver"
2
3DEPENDS = "common-csl-ip"
4
5include dfe-lld.inc
6
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
8
9do_compile () {
10 oe_runmake lib DEVICE=k2l
11}
12
13do_install () {
14 oe_runmake install INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
15}