diff options
Diffstat (limited to 'meta-ti-extras')
-rw-r--r-- | meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb | 2 | ||||
-rw-r--r-- | meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch | 32 |
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb b/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb index 62b4645c..81e544f7 100644 --- a/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb +++ b/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb | |||
@@ -17,3 +17,5 @@ COMPATIBLE_MACHINE = "dra7xx" | |||
17 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 17 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
18 | 18 | ||
19 | include dsptop.inc | 19 | include dsptop.inc |
20 | |||
21 | SRC_URI += "file://0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch" | ||
diff --git a/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch b/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch new file mode 100644 index 00000000..19c6791e --- /dev/null +++ b/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 5a514f6a6bb1c49bdbaf8eabc1776f54851227af Mon Sep 17 00:00:00 2001 | ||
2 | From: Ryan Eatmon <reatmon@ti.com> | ||
3 | Date: Sun, 4 Aug 2024 11:17:28 -0500 | ||
4 | Subject: [PATCH] debugss_kmodule: Add include for mod_devicetable.h | ||
5 | |||
6 | Add include for <linux/mod_devicetable.h> to fix compile error: | ||
7 | |||
8 | git/debugss_module/debugss-mod/debugss_kmodule.c:1149:34: error: | ||
9 | array type has incomplete element type 'struct of_device_id' | ||
10 | |||
11 | Upstream-Status: Inactive-Upstream | ||
12 | |||
13 | Signed-off-by: Ryan Eatmon <reatmon@ti.com> | ||
14 | --- | ||
15 | debugss_kmodule.c | 2 ++ | ||
16 | 1 file changed, 2 insertions(+) | ||
17 | |||
18 | diff --git a/debugss_kmodule.c b/debugss_kmodule.c | ||
19 | index 6fac61d..9e084eb 100644 | ||
20 | --- a/debugss_kmodule.c | ||
21 | +++ b/debugss_kmodule.c | ||
22 | @@ -26,6 +26,8 @@ | ||
23 | #include <linux/of_device.h> | ||
24 | #include "debugss_kmodule.h" | ||
25 | |||
26 | +#include <linux/mod_devicetable.h> | ||
27 | + | ||
28 | /* un-comment the line below to enable printing for kernel debug messages */ | ||
29 | //#define DEBUGSS_DRV_DEBUG | ||
30 | |||
31 | -- | ||
32 | 2.17.1 | ||