summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb2
-rw-r--r--meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch32
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb b/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb
index 62b4645c..81e544f7 100644
--- a/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb
+++ b/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb
@@ -17,3 +17,5 @@ COMPATIBLE_MACHINE = "dra7xx"
17PACKAGE_ARCH = "${MACHINE_ARCH}" 17PACKAGE_ARCH = "${MACHINE_ARCH}"
18 18
19include dsptop.inc 19include dsptop.inc
20
21SRC_URI += "file://0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch"
diff --git a/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch b/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch
new file mode 100644
index 00000000..19c6791e
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch
@@ -0,0 +1,32 @@
1From 5a514f6a6bb1c49bdbaf8eabc1776f54851227af Mon Sep 17 00:00:00 2001
2From: Ryan Eatmon <reatmon@ti.com>
3Date: Sun, 4 Aug 2024 11:17:28 -0500
4Subject: [PATCH] debugss_kmodule: Add include for mod_devicetable.h
5
6Add include for <linux/mod_devicetable.h> to fix compile error:
7
8git/debugss_module/debugss-mod/debugss_kmodule.c:1149:34: error:
9array type has incomplete element type 'struct of_device_id'
10
11Upstream-Status: Inactive-Upstream
12
13Signed-off-by: Ryan Eatmon <reatmon@ti.com>
14---
15 debugss_kmodule.c | 2 ++
16 1 file changed, 2 insertions(+)
17
18diff --git a/debugss_kmodule.c b/debugss_kmodule.c
19index 6fac61d..9e084eb 100644
20--- a/debugss_kmodule.c
21+++ b/debugss_kmodule.c
22@@ -26,6 +26,8 @@
23 #include <linux/of_device.h>
24 #include "debugss_kmodule.h"
25
26+#include <linux/mod_devicetable.h>
27+
28 /* un-comment the line below to enable printing for kernel debug messages */
29 //#define DEBUGSS_DRV_DEBUG
30
31--
322.17.1