summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2024-08-04 11:49:26 -0500
committerRyan Eatmon <reatmon@ti.com>2024-08-04 12:02:01 -0500
commit14d242a035bc45989df43d953134794a9c3705c7 (patch)
tree1cb088409f9e1aa325caf9444c0d393f50da5a83 /meta-ti-extras
parent84d5cee1f1aa23897a32b0d1bd59ab76d391b1d1 (diff)
downloadmeta-ti-14d242a035bc45989df43d953134794a9c3705c7.tar.gz
debugss-module-drv: Fix compile failure under kernel v6.10
A compile error has apperaed when building againt the v6.10 kernel. git/debugss_module/debugss-mod/debugss_kmodule.c:1149:34: error: array type has incomplete element type 'struct of_device_id' 1149 | static const struct of_device_id dra7xx_debugss_of_match[] = { | ^~~~~~~~~~~~~~~~~~~~~~~ The easy fix is just to add an include for the header that defines the missing struct. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb2
-rw-r--r--meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch32
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb b/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb
index 62b4645c..81e544f7 100644
--- a/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb
+++ b/meta-ti-extras/recipes-bsp/dsptop/debugss-module-drv_git.bb
@@ -17,3 +17,5 @@ COMPATIBLE_MACHINE = "dra7xx"
17PACKAGE_ARCH = "${MACHINE_ARCH}" 17PACKAGE_ARCH = "${MACHINE_ARCH}"
18 18
19include dsptop.inc 19include dsptop.inc
20
21SRC_URI += "file://0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch"
diff --git a/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch b/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch
new file mode 100644
index 00000000..19c6791e
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/dsptop/files/0001-debugss_kmodule-Add-include-for-mod_devicetable.h.patch
@@ -0,0 +1,32 @@
1From 5a514f6a6bb1c49bdbaf8eabc1776f54851227af Mon Sep 17 00:00:00 2001
2From: Ryan Eatmon <reatmon@ti.com>
3Date: Sun, 4 Aug 2024 11:17:28 -0500
4Subject: [PATCH] debugss_kmodule: Add include for mod_devicetable.h
5
6Add include for <linux/mod_devicetable.h> to fix compile error:
7
8git/debugss_module/debugss-mod/debugss_kmodule.c:1149:34: error:
9array type has incomplete element type 'struct of_device_id'
10
11Upstream-Status: Inactive-Upstream
12
13Signed-off-by: Ryan Eatmon <reatmon@ti.com>
14---
15 debugss_kmodule.c | 2 ++
16 1 file changed, 2 insertions(+)
17
18diff --git a/debugss_kmodule.c b/debugss_kmodule.c
19index 6fac61d..9e084eb 100644
20--- a/debugss_kmodule.c
21+++ b/debugss_kmodule.c
22@@ -26,6 +26,8 @@
23 #include <linux/of_device.h>
24 #include "debugss_kmodule.h"
25
26+#include <linux/mod_devicetable.h>
27+
28 /* un-comment the line below to enable printing for kernel debug messages */
29 //#define DEBUGSS_DRV_DEBUG
30
31--
322.17.1