summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-devtools/gdbc6x/gdbc6x_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-devtools/gdbc6x/gdbc6x_git.bb')
-rw-r--r--meta-ti-extras/recipes-devtools/gdbc6x/gdbc6x_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbc6x_git.bb b/meta-ti-extras/recipes-devtools/gdbc6x/gdbc6x_git.bb
new file mode 100644
index 00000000..df9aaee9
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbc6x_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "GNU debugger for TI C6X DSP."
2SECTION = "devel"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=bf0fe2872eb3dfeebb2cbe38206fe81f"
5
6DEPENDS = "ncurses bison-native texinfo flex-native gettext"
7
8COMPATIBLE_MACHINE = "dra7xx"
9
10PR = "${INC_PR}.1"
11
12SRC_URI:append = " \
13 file://init \
14 file://0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch;striplevel=2 \
15"
16
17S = "${WORKDIR}/git/gdbc6x"
18
19inherit update-rc.d
20inherit gettext
21
22CFLAGS += "-fcommon"
23
24do_configure () {
25 cd ${S}
26 ./configure --program-suffix=c6x --target=tic6x-elf-tirtos --host=${HOST_SYS} --prefix=${S}/install_gdb
27}
28
29do_install () {
30 make install
31
32 # Custom install to prevent conflict with standard GDB.
33 install -d ${D}${bindir}
34 install -d ${D}${includedir}
35 install -m 755 ${S}/install_gdb/bin/gdbc6x ${D}${bindir}
36 cp -rf ${S}/install_gdb/include/* ${D}${includedir}
37
38 install -d ${D}${sysconfdir}/init.d
39 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/gdbserverproxy
40}
41
42RDEPENDS:${PN} = "gdbserverproxy-module-drv bash"
43
44include gdbc6x.inc
45
46INITSCRIPT_NAME = "gdbserverproxy"
47INITSCRIPT_PARAMS = "defaults 95"
48
49PARALLEL_MAKE = ""