summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.6.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.6.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.6.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.6.bb
new file mode 100644
index 00000000..adc10a01
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.6.bb
@@ -0,0 +1,44 @@
1SECTION = "kernel"
2SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5
6inherit ti-secdev
7inherit kernel
8
9DEFAULT_PREFERENCE = "-1"
10
11require recipes-kernel/linux/setup-defconfig.inc
12require recipes-kernel/linux/ti-kernel.inc
13include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
14include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''}
15
16DEPENDS += "gmp-native libmpc-native"
17
18# Look in the generic major.minor directory for files
19FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-6.6:"
20
21KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
22 ${EXTRA_DTC_ARGS}"
23
24S = "${WORKDIR}/git"
25
26BRANCH ?= "ti-linux-6.6.y"
27
28SRCREV ?= "ffc253263a1375a65fa6c9f62a893e9767fbebfa"
29PV = "6.6.0+git${SRCPV}"
30
31# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
32MACHINE_KERNEL_PR:append = "b"
33PR = "${MACHINE_KERNEL_PR}"
34
35KERNEL_GIT_URI ?= "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git"
36KERNEL_GIT_PROTOCOL = "https"
37SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
38 file://defconfig"
39
40# Special configuration for remoteproc/rpmsg IPC modules
41module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
42module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
43module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
44KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"