summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
deleted file mode 100644
index c53ae1e1..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1SECTION = "kernel"
2SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5
6KERNEL_CLASSES += "${@bb.utils.contains('TFA_PLATFORM', 'k3', 'kernel-fitimage-ti-u-boot', '', d)}"
7
8inherit kernel
9
10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
11require recipes-kernel/linux/setup-defconfig.inc
12require recipes-kernel/linux/ti-kernel.inc
13include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
14
15DEPENDS += "gmp-native libmpc-native"
16
17# Look in the generic major.minor directory for files
18FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.10:"
19
20KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
21 ${EXTRA_DTC_ARGS}"
22
23S = "${WORKDIR}/git"
24
25BRANCH = "ti-linux-5.10.y"
26
27SRCREV = "991c5ce91e43cb620f534dc9fe7b0ad21f4f4388"
28PV = "5.10.168+git${SRCPV}"
29
30# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
31MACHINE_KERNEL_PR:append = "b"
32PR = "${MACHINE_KERNEL_PR}"
33
34KERNEL_GIT_URI = "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git"
35KERNEL_GIT_PROTOCOL = "https"
36SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
37 file://init_disassemble_info-signature-changes-causes-compile-failures.patch \
38 file://0001-ata-ahci-fix-enum-constants-for-gcc-13.patch \
39 file://defconfig"
40
41FILES:${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb"
42
43# Special configuration for remoteproc/rpmsg IPC modules
44module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
45module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
46module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
47KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
48KERNEL_MODULE_AUTOLOAD:append:j721e = " rpmsg_kdrv_switch"