summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
index e2908951..b540e508 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
@@ -19,21 +19,6 @@ PV = "6.1.0-rc1+git${SRCPV}"
19 19
20SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master" 20SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master"
21 21
22def list_dtbs(dts_dir, dts_subdir):
23 import os
24 import fnmatch
25 matches = []
26
27 for root,dirnames,filenames in os.walk(os.path.join(dts_dir, dts_subdir)):
28 for filename in fnmatch.filter(filenames, '*.dtb'):
29 matches.append(os.path.join(dts_subdir, filename))
30 for filename in fnmatch.filter(filenames, '*.dtbo'):
31 matches.append(os.path.join(dts_subdir, filename))
32 return ' '.join(matches)
33
34DTS_SUBDIR = ""
35DTS_SUBDIR:k3 = "ti"
36KERNEL_DEVICETREE = "${@list_dtbs('${B}/arch/${ARCH}/boot/dts', '${DTS_SUBDIR}')}"
37DEFCONFIG_NAME = "multi_v7_defconfig" 22DEFCONFIG_NAME = "multi_v7_defconfig"
38DEFCONFIG_NAME:k3 = "defconfig" 23DEFCONFIG_NAME:k3 = "defconfig"
39KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" 24KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"