diff options
Diffstat (limited to 'meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb')
-rw-r--r-- | meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb new file mode 100644 index 00000000..1e66acd2 --- /dev/null +++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | # PowerVR Graphics require several patches that have not made their way | ||
2 | # upstream yet. This allows us to build the shims we need without completely | ||
3 | # clobbering mesa. | ||
4 | |||
5 | DEFAULT_PREFERENCE = "-1" | ||
6 | |||
7 | require recipes-graphics/mesa/mesa.inc | ||
8 | |||
9 | SUMMARY += " (with PowerVR support for TI platforms)" | ||
10 | |||
11 | LIC_FILES_CHKSUM = "file://docs/license.rst;md5=63779ec98d78d823a9dc533a0735ef10" | ||
12 | |||
13 | BRANCH = "powervr/${PV}" | ||
14 | |||
15 | SRC_URI = " \ | ||
16 | git://gitlab.freedesktop.org/StaticRocket/mesa.git;protocol=https;branch=${BRANCH} \ | ||
17 | file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \ | ||
18 | file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \ | ||
19 | file://0001-gallium-Fix-build-with-llvm-17.patch \ | ||
20 | file://0001-meson-Disable-cmake-dependency-detector-for-llvm.patch \ | ||
21 | " | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | PACKAGECONFIG:append = " \ | ||
26 | ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver', 'pvr', '', d)} \ | ||
27 | ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \ | ||
28 | " | ||
29 | |||
30 | SRCREV = "b12290126ba6a154f0e8b0a8c8b2b0d64f98e427" | ||
31 | |||
32 | PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss" | ||
33 | PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS}," | ||
34 | PACKAGECONFIG[sgx] = "-Dgallium-sgx-alias=${PVR_DISPLAY_CONTROLLER_ALIAS}," | ||
35 | |||
36 | PACKAGECONFIG:remove = "video-codecs" | ||
37 | PACKAGECONFIG[video-codecs] = "" | ||
38 | PACKAGECONFIG:remove = "elf-tls" | ||
39 | PACKAGECONFIG[elf-tls] = "" | ||
40 | PACKAGECONFIG:remove = "xvmc" | ||
41 | PACKAGECONFIG[xvmc] = "" | ||
42 | |||
43 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
44 | |||
45 | GALLIUMDRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'pvr', ',pvr', '', d)}" | ||
46 | GALLIUMDRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'sgx', ',sgx', '', d)}" | ||
47 | |||
48 | VULKAN_DRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'pvr', ',pvr', '', d)}" | ||
49 | |||
50 | do_install:append () { | ||
51 | # remove pvr custom pkgconfig | ||
52 | rm -rf ${D}${datadir}/pkgconfig | ||
53 | } | ||
54 | |||
55 | FILES:${PN}-dev += "${datadir}/mesa/wayland-drm.xml" | ||
56 | FILES:mesa-vulkan-drivers += "${libdir}/libpvr_mesa_wsi.so" | ||
57 | |||
58 | RRECOMMENDS:mesa-megadriver:append:class-target = " ${@d.getVar('PREFERRED_PROVIDER_virtual/gpudriver')}" | ||