summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
new file mode 100644
index 00000000..c7b2a7bb
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "VPDMA firmware for Video Input Port and Video Processing Engine"
2
3LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fd463c9500441ed91d07a0331baa635c"
5
6COMPATIBLE_MACHINE = "dra7xx"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9DEPENDS += "virtual/kernel"
10
11SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vpdma-fw/03-2012/exports/vpdma-fw_03-2012.tar.gz;protocol=http;name=dra7xx-evm"
12SRC_URI[dra7xx-evm.md5sum] = "80176df1350c21d9efa90171789c546e"
13SRC_URI[dra7xx-evm.sha256sum] = "a0b254ffd0c7f481cb3989e632088f5e4a233c73a1c676faa3061721ea60dc90"
14
15S = "${WORKDIR}/vpdma-fw-${PV}"
16TARGET = "vpdma-1b8.bin"
17
18do_install() {
19 mkdir -p ${D}${base_libdir}/firmware
20 cp ${S}/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
21}
22
23FILES:${PN} += "${base_libdir}/firmware/${TARGET}"
24
25PR = "r1"