summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch')
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch b/meta-ti-bsp/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch
new file mode 100644
index 00000000..196f3d3f
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch
@@ -0,0 +1,64 @@
1From 2efc79702a47f9cbbeecbb2f604577f1ec8c95ba Mon Sep 17 00:00:00 2001
2From: Yogesh Siraswar <yogeshs@ti.com>
3Date: Wed, 8 Dec 2021 17:50:19 -0600
4Subject: [KIG PATCH] Makefile: Skip signing of binaries for combined boot hs
5 images
6
7Combined sysfw binaries used in tiboot.bin do not require signed images.
8This fixes issues with AM64x HS and J7200 HS boot images
9
10Upstream-Status: Submitted
11Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
12---
13 Makefile | 8 +++++++-
14 soc/am64x/Makefile | 1 +
15 soc/j7200/Makefile | 1 +
16 3 files changed, 9 insertions(+), 1 deletion(-)
17
18diff --git a/Makefile b/Makefile
19index 47b3b20..ab465df 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -215,8 +215,14 @@ $(soc_objroot)/%.o: %.c
23 $(CROSS_COMPILE)gcc $(CFLAGS) -c -o $@-pre-validated $<
24 python3 ./scripts/sysfw_boardcfg_validator.py -b $@-pre-validated -i -o $@ -s $(SOC) -l $@.log
25
26-# On HS board configuration binaries must be signed
27+# On HS board configuration binaries must be signed unless it is combined boot image
28 ifdef HS
29+ifndef COMBINED_BOOT_IMAGE
30+SIGN_BINARY=1
31+endif
32+endif
33+
34+ifdef SIGN_BINARY
35 %.bin.unsigned: %.o
36 $(CROSS_COMPILE)objcopy -S -O binary $< $@
37 %.bin: %.bin.unsigned
38diff --git a/soc/am64x/Makefile b/soc/am64x/Makefile
39index bfbe3e5..33ebbd0 100644
40--- a/soc/am64x/Makefile
41+++ b/soc/am64x/Makefile
42@@ -31,6 +31,7 @@
43 #
44
45 SBL_LOADADDDR ?= 0x70000000
46+COMBINED_BOOT_IMAGE = 1
47 COMBINED_SYSFW_BRDCFG_LOADADDR ?= 0x7b000
48 LOADADDR ?= 0x44000
49 SCIFS = sci
50diff --git a/soc/j7200/Makefile b/soc/j7200/Makefile
51index 3b754f7..0baef51 100644
52--- a/soc/j7200/Makefile
53+++ b/soc/j7200/Makefile
54@@ -31,6 +31,7 @@
55 #
56
57 SBL_LOADADDDR ?= 0x41c00000
58+COMBINED_BOOT_IMAGE = 1
59 COMBINED_TIFS_BRDCFG_LOADADDR ?= 0x7f000
60 COMBINED_DM_BRDCFG_LOADADDR ?= 0x41c80000
61 LOADADDR ?= 0x40000
62--
632.17.1
64