summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/bt-fw/bt-fw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/bt-fw/bt-fw_git.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/bt-fw/bt-fw_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/bt-fw/bt-fw_git.bb b/meta-ti-bsp/recipes-bsp/bt-fw/bt-fw_git.bb
new file mode 100644
index 00000000..ea42c168
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/bt-fw/bt-fw_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Firmware files for Bluetooth"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=f39eac9f4573be5b012e8313831e72a9"
4
5PV = "8.7.1+git${SRCPV}"
6
7CLEANBROKEN = "1"
8
9SRCREV = "0ee619b598d023fffc77679f099bc2a4815510e4"
10BRANCH = "master"
11SRC_URI = "git://git.ti.com/ti-bt/service-packs.git;branch=${BRANCH}"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16 :
17}
18
19do_install() {
20 install -d ${D}${base_libdir}/firmware/ti-connectivity
21 oe_runmake "DEST_DIR=${D}" "BASE_LIB_DIR=${base_libdir}" install
22}
23
24FILES:${PN} += "${base_libdir}/firmware/ti-connectivity/*"