summaryrefslogtreecommitdiffstats
path: root/extras/recipes-ti/gstreamer-ti/gstreamer-ti/0010-replace-omap3530_dv400-platform-support-with-omap353.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-ti/gstreamer-ti/gstreamer-ti/0010-replace-omap3530_dv400-platform-support-with-omap353.patch')
-rw-r--r--extras/recipes-ti/gstreamer-ti/gstreamer-ti/0010-replace-omap3530_dv400-platform-support-with-omap353.patch119
1 files changed, 119 insertions, 0 deletions
diff --git a/extras/recipes-ti/gstreamer-ti/gstreamer-ti/0010-replace-omap3530_dv400-platform-support-with-omap353.patch b/extras/recipes-ti/gstreamer-ti/gstreamer-ti/0010-replace-omap3530_dv400-platform-support-with-omap353.patch
new file mode 100644
index 00000000..85550e6c
--- /dev/null
+++ b/extras/recipes-ti/gstreamer-ti/gstreamer-ti/0010-replace-omap3530_dv400-platform-support-with-omap353.patch
@@ -0,0 +1,119 @@
1From 0f2ef84ad320ec141a7ba6727cf18817ac42e413 Mon Sep 17 00:00:00 2001
2From: Brijesh Singh <bksingh@ti.com>
3Date: Mon, 4 Oct 2010 14:11:39 -0500
4Subject: [PATCH] replace omap3530_dv400 platform support with omap3530
5
6---
7 Makefile.external | 19 +++----------
8 src/gstticodecplugin_omap3530_dv400.cfg | 44 -------------------------------
9 2 files changed, 5 insertions(+), 58 deletions(-)
10 delete mode 100644 src/gstticodecplugin_omap3530_dv400.cfg
11
12diff --git a/Makefile.external b/Makefile.external
13index 6d118d8..2a85108 100644
14--- a/Makefile.external
15+++ b/Makefile.external
16@@ -8,7 +8,7 @@
17 # Copyright (C) 2009 Ridgerun
18 #
19
20-.PHONY: default configure dm6446 omap3530 dm355 dm6467 dm365 omapl138 omap3530_dv400
21+.PHONY: default configure dm6446 omap3530 dm355 dm6467 dm365 omapl138
22
23 DVSDK_PATH=undefined
24 DMAI_INSTALL_DIR=undefined
25@@ -23,7 +23,7 @@ $(error You need to define the environment variable DMAI_INSTALL_DIR)
26 endif
27
28 default:
29- @echo "Please specify the target: dm6446, omap3530, dm355, dm6467, dm6467t, dm365 omapl138 omap3530_dv400"
30+ @echo "Please specify the target: dm6446, omap3530, dm355, dm6467, dm6467t, dm365 omapl138"
31
32 export GST_TI_PLATFORM=$(MAKECMDGOALS)
33 export BIOS_INSTALL_DIR
34@@ -87,6 +87,9 @@ ifeq ($(GST_TI_PLATFORM), omap3530)
35 export MVTOOL_DIR = $(CSTOOL_DIR)
36 export PLATFORM_XDC = ${XDC_PLATFORM}
37 export CROSS_COMPILE = ${CSTOOL_PREFIX}
38+ export LINK_XDC_ROOT = $(LINK_INSTALL_DIR)
39+ export C6ACCEL_INSTALL_DIR
40+ export ENABLE_C6ACCEL ="--enable-c6accel"
41 endif
42
43 ifeq ($(GST_TI_PLATFORM), omapl138)
44@@ -101,16 +104,6 @@ ifeq ($(GST_TI_PLATFORM), omapl138)
45 export ENABLE_C6ACCEL ="--enable-c6accel"
46 endif
47
48-ifeq ($(GST_TI_PLATFORM), omap3530_dv400)
49- export XDC_TARGET = gnu.targets.arm.GCArmv5T
50- export XDC_PLATFORM = ti.platforms.evm3530
51- export MVTOOL_PREFIX = $(CSTOOL_PREFIX)
52- export MVTOOL_DIR = $(CSTOOL_DIR)
53- export PLATFORM_XDC = ${XDC_PLATFORM}
54- export CROSS_COMPILE = ${CSTOOL_PREFIX}
55- export LINK_XDC_ROOT = $(LINK_INSTALL_DIR)
56-endif
57-
58 CPPFLAGS=-DPlatform_$(GST_TI_PLATFORM)
59 HOST=arm-none-linux-gnueabi
60
61@@ -141,5 +134,3 @@ dm365: Makefile
62 omapl138: Makefile
63 $(MAKE) -f Makefile
64
65-omap3530_dv400: Makefile
66- $(MAKE) -f Makefile
67diff --git a/src/gstticodecplugin_omap3530_dv400.cfg b/src/gstticodecplugin_omap3530_dv400.cfg
68deleted file mode 100644
69index 90f4edf..0000000
70--- a/src/gstticodecplugin_omap3530_dv400.cfg
71+++ /dev/null
72@@ -1,44 +0,0 @@
73-/*
74- * Copyright (C) 2008-2010 Texas Instruments Incorporated - http://www.ti.com/
75- *
76- * This program is free software; you can redistribute it and/or modify
77- * it under the terms of the GNU Lesser General Public License as
78- * published by the Free Software Foundation version 2.1 of the License.
79- *
80- * This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
81- * whether express or implied; without even the implied warranty of
82- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
83- * Lesser General Public License for more details.
84- *
85- */
86-
87-/* Load the Codec Engine 'Operating System Abstraction Layer' */
88-var osalGlobal = xdc.useModule('ti.sdo.ce.osal.Global');
89-
90-var os = xdc.useModule('ti.sdo.ce.osal.linux.Settings');
91-osalGlobal.os = os;
92-
93-/* Configure CE to use it's DSP Link Linux version */
94-var ipc = xdc.useModule('ti.sdo.ce.ipc.Settings');
95-ipc.commType = ipc.COMM_DSPLINK;
96-
97-/*
98- * ======== Engine Configuration ========
99- */
100-var Engine = xdc.useModule('ti.sdo.ce.Engine');
101-var demoEngine = Engine.createFromServer(
102- "codecServer",
103- "./bin/cs.x64P",
104- "ti.sdo.server.cs"
105- );
106-
107-var combopath = "" + java.lang.System.getenv("CODEC_SERVER");
108-if (combopath != "" && combopath != "null") {
109- demoEngine.server = java.lang.System.getenv("CODEC_SERVER");
110-}
111-
112-/* Load support for the DMAI module */
113-var DMAI = xdc.loadPackage('ti.sdo.dmai');
114-
115-var SCPY = xdc.useModule('ti.sdo.fc.scpy.SCPY');
116-var SDMA = xdc.useModule('ti.sdo.linuxutils.sdma.SDMA');
117--
1181.7.0.4
119