summaryrefslogtreecommitdiffstats
path: root/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch')
-rw-r--r--extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch288
1 files changed, 288 insertions, 0 deletions
diff --git a/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch b/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch
new file mode 100644
index 00000000..fa4cb2e6
--- /dev/null
+++ b/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch
@@ -0,0 +1,288 @@
1From fd5858c3a247bc61a4de3af1a5097cb05042cfa4 Mon Sep 17 00:00:00 2001
2From: Roger Monk <r-monk@ti.com>
3Date: Sun, 14 Mar 2010 22:13:42 +0000
4Subject: [PATCH] omap1
5
6Signed-off-by: Roger Monk <r-monk@ti.com>
7---
8 dsplink/config/bin/dsplinkcfg.pl | 2 +-
9 dsplink/gpp/src/DIRS | 5 +
10 dsplink/gpp/src/Makefile | 8 ++-
11 dsplink/make/Linux/omapl1xx_arm.mk | 210 ++++++++++++++++++++++++++++++++++++
12 4 files changed, 223 insertions(+), 2 deletions(-)
13 create mode 100644 dsplink/make/Linux/omapl1xx_arm.mk
14
15diff --git a/dsplink/config/bin/dsplinkcfg.pl b/dsplink/config/bin/dsplinkcfg.pl
16index e83c133..8151945 100644
17--- a/dsplink/config/bin/dsplinkcfg.pl
18+++ b/dsplink/config/bin/dsplinkcfg.pl
19@@ -523,7 +523,7 @@ my %CFG_DSPCFG_OMAPL1XXGEMSHMEM =
20 'PHYID' => 'OMAPL1XXGEMSHMEM',
21 'PHYDESC' => 'Shared Memory Physical Interface',
22 'PHYTYPE' => 'SHMEM',
23- 'GPPOS' => [\%CFG_GPPOS_MVL5U, \%CFG_GPPOS_MVL5G],
24+ 'GPPOS' => [\%CFG_GPPOS_MVL5U, \%CFG_GPPOS_MVL5G, \%CFG_GPPOS_ARM],
25 'DSPOS' => [\%CFG_DSPOS_5XX],
26 # DSP defines
27 'DSPNAME' => 'OMAPL1XXGEM',
28diff --git a/dsplink/gpp/src/DIRS b/dsplink/gpp/src/DIRS
29index 05bad2b..af48904 100644
30--- a/dsplink/gpp/src/DIRS
31+++ b/dsplink/gpp/src/DIRS
32@@ -55,6 +55,10 @@ ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
33 DIRS += \
34 api
35 else # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
36+ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL1XX")
37+DIRS += \
38+ api
39+else # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL1XX")
40 ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAP3530")
41 DIRS += \
42 api
43@@ -83,6 +87,7 @@ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
44 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
45 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
46 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
47+endif
48 else # ifeq ("$(TI_DSPLINK_GPPOS)", "Linux")
49 DIRS += \
50 arch \
51diff --git a/dsplink/gpp/src/Makefile b/dsplink/gpp/src/Makefile
52index 49c3b97..0afd988 100644
53--- a/dsplink/gpp/src/Makefile
54+++ b/dsplink/gpp/src/Makefile
55@@ -83,7 +83,13 @@ ifeq ("$(TI_DSPLINK_GPPOS)", "Linux")
56 include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Rules.mk
57 include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_kbuild
58 else # else ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
59- include Makefile_bld
60+ ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL1XX")
61+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_bld
62+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Rules.mk
63+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_kbuild
64+ else # else ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
65+ include Makefile_bld
66+ endif
67 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
68 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAP3530")
69 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
70diff --git a/dsplink/make/Linux/omapl1xx_arm.mk b/dsplink/make/Linux/omapl1xx_arm.mk
71new file mode 100644
72index 0000000..3e42e87
73--- /dev/null
74+++ b/dsplink/make/Linux/omapl1xx_arm.mk
75@@ -0,0 +1,210 @@
76+# ============================================================================
77+# @file omapl1xx_arm.mk
78+#
79+# @path $(DSPLINK)/make/Linux/
80+#
81+# @desc This makefile defines OS specific macros used by MAKE system for
82+# the Montavista Pro 5.0 Linux distribution with mvlpro.
83+#
84+# @ver 1.64
85+# ============================================================================
86+# Copyright (C) 2002-2009, Texas Instruments Incorporated -
87+# http://www.ti.com/
88+#
89+# Redistribution and use in source and binary forms, with or without
90+# modification, are permitted provided that the following conditions
91+# are met:
92+#
93+# * Redistributions of source code must retain the above copyright
94+# notice, this list of conditions and the following disclaimer.
95+#
96+# * Redistributions in binary form must reproduce the above copyright
97+# notice, this list of conditions and the following disclaimer in the
98+# documentation and/or other materials provided with the distribution.
99+#
100+# * Neither the name of Texas Instruments Incorporated nor the names of
101+# its contributors may be used to endorse or promote products derived
102+# from this software without specific prior written permission.
103+#
104+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
105+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
106+# THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
107+# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
108+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
109+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
110+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
111+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
112+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
113+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
114+# EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
115+# ============================================================================
116+
117+ifndef OMAPL1XX_ARM_MK
118+
119+define OMAPL1XX_ARM_MK
120+endef
121+
122+
123+# ============================================================================
124+# Let the make system know that a specific distribution for the GPP OS
125+# is being used.
126+# ============================================================================
127+USE_DISTRIBUTION := 1
128+
129+
130+# ============================================================================
131+# Set the values of necessary variables to be used for the OS.
132+# ============================================================================
133+
134+# ----------------------------------------------------------------------------
135+# Base directory for the GPP OS
136+# ----------------------------------------------------------------------------
137+BASE_BUILDOS := ${HOME}/da850/DaVinci-PSP-SDK-03.20.00.01/src/kernel/linux-03.20.00.01
138+
139+# ----------------------------------------------------------------------------
140+# Base for toolchain
141+# ----------------------------------------------------------------------------
142+BASE_TOOLCHAIN := ${HOME}/git/arm-2008q3
143+
144+# ----------------------------------------------------------------------------
145+# Base for code generation tools - compiler, linker, archiver etc.
146+# ----------------------------------------------------------------------------
147+BASE_CGTOOLS := $(BASE_TOOLCHAIN)/bin
148+
149+# ----------------------------------------------------------------------------
150+# Base directory for include files provided by GPP OS
151+# ----------------------------------------------------------------------------
152+BASE_OSINC := $(BASE_BUILDOS)/include
153+
154+OSINC_GENERIC := $(BASE_OSINC)
155+OSINC_PLATFORM := $(BASE_TOOLCHAIN)/lib/gcc/arm-none-linux-gnueabi/4.3.2/include
156+OSINC_TARGET := $(BASE_TOOLCHAIN)/arm-none-linux-gnueabi/libc/usr/include
157+
158+ifneq ("$(VARIANT)", "")
159+OSINC_VARIANT := $(BASE_OSINC)
160+endif
161+
162+
163+# ----------------------------------------------------------------------------
164+# Base directory for libraries provided by GPP OS
165+# ----------------------------------------------------------------------------
166+BASE_OSLIB := $(BASE_TOOLCHAIN)/lib
167+
168+OSLIB_GENERIC := $(BASE_OSLIB)
169+OSLIB_PLATFORM := $(BASE_OSLIB)
170+
171+
172+ifneq ("$(VARIANT)", "")
173+OSLIB_VARIANT := $(BASE_OSLIB)
174+endif
175+
176+
177+# ============================================================================
178+# COMPILER
179+# ============================================================================
180+
181+# ----------------------------------------------------------------------------
182+# Name of the compiler
183+# ----------------------------------------------------------------------------
184+COMPILER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-gcc
185+LD := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-ld
186+
187+CROSS_COMPILE := arm-none-linux-gnueabi-
188+export CROSS_COMPILE
189+
190+# ----------------------------------------------------------------------------
191+# Command line switches used by the compiler
192+#
193+# CC_SW_DEF Command line defines
194+# CC_SW_INC Search path for header files
195+# CC_SW_OBJ Create object file
196+# CC_SW_DEB Include debug information
197+# ----------------------------------------------------------------------------
198+CC_SW_DEF := -D
199+CC_SW_INC := -I
200+CC_SW_OBJ := -o
201+CC_SW_DEB := -g
202+
203+# ----------------------------------------------------------------------------
204+# Standard flags for the compiler
205+# ----------------------------------------------------------------------------
206+STD_USER_FLAGS := -Wall -c
207+
208+# ----------------------------------------------------------------------------
209+# Standard flags for the compiler when building an executable
210+# ----------------------------------------------------------------------------
211+EXE_CC_FLAGS :=
212+
213+# ----------------------------------------------------------------------------
214+# Flags for the compiler when building a driver
215+# ----------------------------------------------------------------------------
216+DRV_CC_FLAGS := -nostdinc
217+
218+# ----------------------------------------------------------------------------
219+# Flags for the compiler when building a library
220+# ----------------------------------------------------------------------------
221+LIB_CC_FLAGS :=
222+
223+# ----------------------------------------------------------------------------
224+# Standard definitions for the compiler
225+# ----------------------------------------------------------------------------
226+STD_CC_DEFNS := -D_REENTRANT
227+
228+# ============================================================================
229+# ARCHIVER2 - This denotes the archiver.
230+# ============================================================================
231+ARCHIVER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-ar
232+
233+# ----------------------------------------------------------------------------
234+# Standard flags for the archiver
235+# ----------------------------------------------------------------------------
236+STD_AR_FLAGS := -rs
237+
238+
239+# ============================================================================
240+# LINKER - The compiler is used for linking purpose as well.
241+# ============================================================================
242+LINKER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-gcc
243+
244+# ----------------------------------------------------------------------------
245+# Command line switches used by the linker
246+#
247+# LD_SW_LIB Search path for libraries
248+# LD_SW_OUT Output filename
249+# LD_SW_RELOC Generate relocateable output
250+# ----------------------------------------------------------------------------
251+LD_SW_LIB := -L
252+LD_SW_OUT := -o
253+LD_SW_RELOC := -r
254+
255+# ----------------------------------------------------------------------------
256+# Standard flags for the linker
257+# ----------------------------------------------------------------------------
258+STD_LD_FLAGS :=
259+
260+# ----------------------------------------------------------------------------
261+# Flags for the linker when building an executable
262+# ----------------------------------------------------------------------------
263+EXE_LD_FLAGS := -lpthread -lc
264+
265+# ----------------------------------------------------------------------------
266+# Flags for the linker when building a driver
267+# ----------------------------------------------------------------------------
268+DRV_LD_FLAGS :=
269+
270+
271+# ============================================================================
272+# Post processing utilities for Linux 2.6
273+# ============================================================================
274+ifneq ($(CONFIG_MODVERSIONS),)
275+CMD_MODPOST_FLAGS := -m -i
276+else
277+CMD_MODPOST_FLAGS := -i
278+endif
279+
280+CMD_MODPOST := $(BASE_BUILDOS)/scripts/mod/modpost \
281+ $(CMD_MODPOST_FLAGS) $(BASE_BUILDOS)/Module.symvers \
282+ $(BASE_BUILDOS)/vmlinux
283+
284+
285+endif # ifndef OMAPL1XX_ARM_MK
286--
2871.6.0.6
288