summaryrefslogtreecommitdiffstats
path: root/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_dm6446_build_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_dm6446_build_support.patch')
-rw-r--r--extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_dm6446_build_support.patch337
1 files changed, 337 insertions, 0 deletions
diff --git a/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_dm6446_build_support.patch b/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_dm6446_build_support.patch
new file mode 100644
index 00000000..5a25dbb5
--- /dev/null
+++ b/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_dm6446_build_support.patch
@@ -0,0 +1,337 @@
1From 7b36e94dcb33892e1df7d3327db31bd41fb6167e Mon Sep 17 00:00:00 2001
2From: Roger Monk <r-monk@ti.com>
3Date: Fri, 5 Mar 2010 19:22:58 +0000
4Subject: [PATCH] dsplink_1_64: Add support for building with CS tools + against 2.6.30+
5
6 * Tweaked Patches from Niclas
7
8Signed-off-by: Roger Monk <r-monk@ti.com>
9---
10 dsplink/config/bin/dsplinkcfg.pl | 17 ++++-
11 dsplink/gpp/src/DIRS | 5 +
12 dslpink/gpp/src/Makefile | 8 ++-
13 dsplink/gpp/src/Rules.mk | 5 +
14 dsplink/make/Linux/davinci_2.6.mk | 211 +++++++++++++++++++++++++++++++++++++++++++++
15 5 files changed, 244 insertions(+), 2 deletions(-)
16 create mode 100644 make/Linux/davinci_2.6.mk
17
18diff --git a/dsplink/config/bin/dsplinkcfg.pl b/dsplink/config/bin/dsplinkcfg.pl
19index 644aa38..e83c133 100644
20--- a/dsplink/config/bin/dsplinkcfg.pl
21+++ b/dsplink/config/bin/dsplinkcfg.pl
22@@ -215,6 +215,18 @@ my %CFG_GPPOS_DM6467LSPuc =
23 'OSPREFIX' => 'uc',
24 ) ;
25
26+# DM6446 Linux
27+my %CFG_GPPOS_DM6446LSP =
28+(
29+ 'NAME' => 'DM6446LSP',
30+ 'PREFIX' => '2.6',
31+ 'ID' => 'DM6446LSP',
32+ 'DESC' => 'DM6446 LSP for DM6446',
33+ 'VER' => '2.6.18',
34+ 'TYPE' => 'Linux',
35+ 'LOADERS'=> [\%CFG_LOADER_COFF, ],
36+ 'COMPS' => 'ponslrmc',
37+) ;
38
39 # OMAPL138 Linux with uCLibc filesystem
40 my %CFG_GPPOS_OMAPL138LSPuc =
41@@ -356,7 +368,7 @@ my %CFG_DSPCFG_DM6446GEMSHMEM =
42 'PHYID' => 'DM6446GEMSHMEM',
43 'PHYDESC' => 'Shared Memory Physical Interface',
44 'PHYTYPE' => 'SHMEM',
45- 'GPPOS' => [\%CFG_GPPOS_MVL5U, \%CFG_GPPOS_MVL5G],
46+ 'GPPOS' => [\%CFG_GPPOS_MVL5U, \%CFG_GPPOS_MVL5G, \%CFG_GPPOS_DM6446LSP],
47 'DSPOS' => [\%CFG_DSPOS_5XX, \%CFG_DSPOS_6XX],
48 # DSP defines
49 'DSPNAME' => 'DM6446GEM',
50@@ -2994,6 +3006,9 @@ sub main {
51 if ($platform {'ID'} eq 'DA850') {
52 print "GPP side distribution file: \$DSPLINK" . $DIRSEP . "gpp" . $DIRSEP. "src" . $DIRSEP. "Rules.mk\n" ;
53 }
54+ if ($platform {'ID'} eq 'DAVINCI') {
55+ print "GPP side distribution file: \$DSPLINK" . $DIRSEP . "gpp" . $DIRSEP. "src" . $DIRSEP. "Rules.mk\n" ;
56+ }
57 if ($platform {'ID'} eq 'DAVINCIHD') {
58 print "GPP side distribution file: \$DSPLINK" . $DIRSEP . "gpp" . $DIRSEP. "src" . $DIRSEP. "Rules.mk\n" ;
59 }
60diff --git a/dsplink/gpp/src/DIRS b/dsplink/gpp/src/DIRS
61index e82969c..05bad2b 100644
62--- a/dsplink/gpp/src/DIRS
63+++ b/dsplink/gpp/src/DIRS
64@@ -63,6 +63,10 @@ ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
65 DIRS += \
66 api
67 else # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
68+ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
69+DIRS += \
70+ api
71+else # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
72 ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
73 DIRS += \
74 api
75@@ -77,6 +81,7 @@ DIRS += \
76 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAP3530")
77 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
78 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
79+endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
80 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
81 else # ifeq ("$(TI_DSPLINK_GPPOS)", "Linux")
82 DIRS += \
83diff --git a/dsplink/gpp/src/Makefile b/dsplink/gpp/src/Makefile
84index 9e6bbb1..49c3b97 100644
85--- a/dsplink/gpp/src/Makefile
86+++ b/dsplink/gpp/src/Makefile
87@@ -78,7 +78,13 @@ ifeq ("$(TI_DSPLINK_GPPOS)", "Linux")
88 include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Rules.mk
89 include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_kbuild
90 else # else ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
91- include Makefile_bld
92+ ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
93+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_bld
94+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Rules.mk
95+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_kbuild
96+ else # else ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
97+ include Makefile_bld
98+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
99 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAP3530")
100 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
101 endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
102diff --git a/dsplink/gpp/src/Rules.mk b/dsplink/gpp/src/Rules.mk
103index 658ee8a..5a6f52a 100644
104--- a/dsplink/gpp/src/Rules.mk
105+++ b/dsplink/gpp/src/Rules.mk
106@@ -63,6 +63,11 @@ KERNEL_DIR := ${HOME}/da850/DaVinci-PSP-SDK-03.20.00.01/src/kernel/linux-03.2
107 TOOL_PATH := ${HOME}/git/arm-2008q3/bin
108 endif #ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
109
110+ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
111+KERNEL_DIR := ${HOME}/linux-davinci
112+TOOL_PATH := ${HOME}/toolchains/git/arm-2009q1-203/bin
113+endif #ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
114+
115 ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
116 KERNEL_DIR := ${HOME}/linux-davinci
117 TOOL_PATH := ${HOME}/toolchains/git/arm-2009q1-203/bin
118diff --git a/dsplink/make/Linux/davinci_2.6.mk b/dsplink/make/Linux/davinci_2.6.mk
119new file mode 100644
120index 0000000..834fd74
121--- /dev/null
122+++ b/dsplink/make/Linux/davinci_2.6.mk
123@@ -0,0 +1,211 @@
124+# ============================================================================
125+# @file davinci_2.6.mk
126+#
127+# @path $(DSPLINK)/make/Linux/
128+#
129+# @desc This makefile defines OS specific macros used by MAKE system for
130+# the Montavista Pro 5.0 Linux distribution.
131+#
132+# @ver 1.64
133+# ============================================================================
134+# Copyright (C) 2002-2009, Texas Instruments Incorporated -
135+# http://www.ti.com/
136+#
137+# Redistribution and use in source and binary forms, with or without
138+# modification, are permitted provided that the following conditions
139+# are met:
140+#
141+# * Redistributions of source code must retain the above copyright
142+# notice, this list of conditions and the following disclaimer.
143+#
144+# * Redistributions in binary form must reproduce the above copyright
145+# notice, this list of conditions and the following disclaimer in the
146+# documentation and/or other materials provided with the distribution.
147+#
148+# * Neither the name of Texas Instruments Incorporated nor the names of
149+# its contributors may be used to endorse or promote products derived
150+# from this software without specific prior written permission.
151+#
152+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
153+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
154+# THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
155+# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
156+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
157+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
158+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
159+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
160+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
161+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
162+# EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
163+# ============================================================================
164+
165+
166+ifndef DAVINCI_LINUX2_6_MK
167+
168+define DAVINCI_LINUX2_6_MK
169+endef
170+
171+
172+# ============================================================================
173+# Let the make system know that a specific distribution for the GPP OS
174+# is being used.
175+# ============================================================================
176+USE_DISTRIBUTION := 1
177+
178+
179+# ============================================================================
180+# Set the values of necessary variables to be used for the OS.
181+# ============================================================================
182+
183+# ----------------------------------------------------------------------------
184+# Base directory for the GPP OS
185+# ----------------------------------------------------------------------------
186+BASE_BUILDOS := ${HOME}/linux-davinci
187+
188+# ----------------------------------------------------------------------------
189+# Base for toolchain
190+# ----------------------------------------------------------------------------
191+BASE_TOOLCHAIN := ${HOME}/toolchains/git/arm-2009q1-203
192+
193+# ----------------------------------------------------------------------------
194+# Base for code generation tools - compiler, linker, archiver etc.
195+# ----------------------------------------------------------------------------
196+BASE_CGTOOLS := $(BASE_TOOLCHAIN)/bin
197+
198+# ----------------------------------------------------------------------------
199+# Base directory for include files provided by GPP OS
200+# ----------------------------------------------------------------------------
201+BASE_OSINC := $(BASE_BUILDOS)/include
202+
203+OSINC_GENERIC := $(BASE_OSINC)
204+OSINC_PLATFORM := $(BASE_TOOLCHAIN)/lib/gcc/arm-none-linux-gnueabi/4.2.3/include
205+OSINC_TARGET := $(BASE_TOOLCHAIN)/arm-none-linux-gnueabi/libc/usr/include
206+
207+ifneq ("$(VARIANT)", "")
208+OSINC_VARIANT := $(BASE_OSINC)
209+endif
210+
211+
212+# ----------------------------------------------------------------------------
213+# Base directory for libraries provided by GPP OS
214+# ----------------------------------------------------------------------------
215+BASE_OSLIB := $(BASE_TOOLCHAIN)/lib
216+
217+OSLIB_GENERIC := $(BASE_OSLIB)
218+OSLIB_PLATFORM := $(BASE_OSLIB)
219+
220+
221+ifneq ("$(VARIANT)", "")
222+OSLIB_VARIANT := $(BASE_OSLIB)
223+endif
224+
225+
226+# ============================================================================
227+# COMPILER
228+# ============================================================================
229+
230+# ----------------------------------------------------------------------------
231+# Name of the compiler
232+# ----------------------------------------------------------------------------
233+COMPILER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-gcc
234+LD := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-ld
235+
236+CROSS_COMPILE := arm-none-linux-gnueabi-
237+export CROSS_COMPILE
238+
239+# ----------------------------------------------------------------------------
240+# Command line switches used by the compiler
241+#
242+# CC_SW_DEF Command line defines
243+# CC_SW_INC Search path for header files
244+# CC_SW_OBJ Create object file
245+# CC_SW_DEB Include debug information
246+# ----------------------------------------------------------------------------
247+CC_SW_DEF := -D
248+CC_SW_INC := -I
249+CC_SW_OBJ := -o
250+CC_SW_DEB := -g
251+
252+# ----------------------------------------------------------------------------
253+# Standard flags for the compiler
254+# ----------------------------------------------------------------------------
255+STD_USER_FLAGS := -Wall -c
256+
257+# ----------------------------------------------------------------------------
258+# Flags for the compiler when building a library
259+# ----------------------------------------------------------------------------
260+EXE_CC_FLAGS :=
261+
262+# ----------------------------------------------------------------------------
263+# Standard flags for the compiler when building an executable
264+# ----------------------------------------------------------------------------
265+DRV_CC_FLAGS := -nostdinc
266+
267+# ----------------------------------------------------------------------------
268+# Flags for the compiler when building a driver
269+# ----------------------------------------------------------------------------
270+LIB_CC_FLAGS :=
271+
272+# ----------------------------------------------------------------------------
273+# Standard definitions for the compiler
274+# ----------------------------------------------------------------------------
275+STD_CC_DEFNS := -D_REENTRANT
276+
277+# ============================================================================
278+# ARCHIVER2 - This denotes the archiver.
279+# ============================================================================
280+ARCHIVER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-ar
281+
282+# ----------------------------------------------------------------------------
283+# Standard flags for the archiver
284+# ----------------------------------------------------------------------------
285+STD_AR_FLAGS := -rs
286+
287+
288+# ============================================================================
289+# LINKER used for Library & Driver build
290+# ============================================================================
291+LINKER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-gcc
292+
293+# ----------------------------------------------------------------------------
294+# Command line switches used by the linker
295+#
296+# LD_SW_LIB Search path for libraries
297+# LD_SW_OUT Output filename
298+# LD_SW_RELOC Generate relocateable output
299+# ----------------------------------------------------------------------------
300+LD_SW_LIB := -L
301+LD_SW_OUT := -o
302+LD_SW_RELOC := -r
303+
304+# ----------------------------------------------------------------------------
305+# Flags for the LD when building an executable
306+# ----------------------------------------------------------------------------
307+STD_LD_FLAGS :=
308+
309+# ----------------------------------------------------------------------------
310+# Standard flags for the LD
311+# ----------------------------------------------------------------------------
312+EXE_LD_FLAGS := -lpthread -lc
313+
314+# ----------------------------------------------------------------------------
315+# Standard flags for the archiver
316+# ----------------------------------------------------------------------------
317+DRV_LD_FLAGS :=
318+
319+
320+# ============================================================================
321+# Post processing utilities for Linux 2.6
322+# ============================================================================
323+ifneq ($(CONFIG_MODVERSIONS),)
324+CMD_MODPOST_FLAGS := -m -i
325+else
326+CMD_MODPOST_FLAGS := -i
327+endif
328+
329+CMD_MODPOST := $(BASE_BUILDOS)/scripts/mod/modpost \
330+ $(CMD_MODPOST_FLAGS) $(BASE_BUILDOS)/Module.symvers \
331+ $(BASE_BUILDOS)/vmlinux
332+
333+
334+endif # ifndef DAVINCI_LINUX2_6_MK
335--
3361.6.0.6
337