summaryrefslogtreecommitdiffstats
path: root/extras/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb')
-rw-r--r--extras/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/extras/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb b/extras/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb
new file mode 100644
index 00000000..e5a38363
--- /dev/null
+++ b/extras/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb
@@ -0,0 +1,28 @@
1require multi-kernel.inc
2
3DESCRIPTION = "Linux kernel for TI81xx processors"
4KERNEL_IMAGETYPE = "uImage"
5
6COMPATIBLE_MACHINE = "am387x-evm|am389x-evm|c6a814x-evm|c6a816x-evm|dm814x-evm"
7
8# This is on the ti81xx-master branch
9SRCREV = "745a06cb913ad7a9ab44855aa36d8c012cd5793b"
10
11# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
12MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}"
13
14SRC_URI += "git://arago-project.org/git/projects/linux-omap3.git;protocol=git;branch=ti81xx-master \
15 file://0001-ti814x-added-code-for-disabling-the-least-significan.patch \
16 file://defconfig"
17
18S = "${WORKDIR}/git"
19
20# Perf in 2.6.37-psp doesn't build, so disable it
21do_compile_perf() {
22 :
23}
24
25do_install_perf() {
26 :
27}
28