summaryrefslogtreecommitdiffstats
path: root/extras/recipes-kernel/linux/linux-omap/wl1271/0012-drivers-media-radio-wl128x-Kconfig-Makefile-for-wl12.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-kernel/linux/linux-omap/wl1271/0012-drivers-media-radio-wl128x-Kconfig-Makefile-for-wl12.patch')
-rw-r--r--extras/recipes-kernel/linux/linux-omap/wl1271/0012-drivers-media-radio-wl128x-Kconfig-Makefile-for-wl12.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/extras/recipes-kernel/linux/linux-omap/wl1271/0012-drivers-media-radio-wl128x-Kconfig-Makefile-for-wl12.patch b/extras/recipes-kernel/linux/linux-omap/wl1271/0012-drivers-media-radio-wl128x-Kconfig-Makefile-for-wl12.patch
new file mode 100644
index 00000000..2e5fda86
--- /dev/null
+++ b/extras/recipes-kernel/linux/linux-omap/wl1271/0012-drivers-media-radio-wl128x-Kconfig-Makefile-for-wl12.patch
@@ -0,0 +1,52 @@
1From 949d2c98bb76cc321e5ef5a96a632d831e5953bf Mon Sep 17 00:00:00 2001
2From: Manjunatha Halli <manjunatha_halli@ti.com>
3Date: Tue, 11 Jan 2011 11:31:26 +0000
4Subject: [PATCH 12/15] drivers:media:radio: wl128x: Kconfig & Makefile for wl128x driver
5
6Signed-off-by: Manjunatha Halli <manjunatha_halli@ti.com>
7Reviewed-by: Hans Verkuil <hverkuil@xs4all.nl>
8---
9 drivers/media/radio/wl128x/Kconfig | 17 +++++++++++++++++
10 drivers/media/radio/wl128x/Makefile | 6 ++++++
11 2 files changed, 23 insertions(+), 0 deletions(-)
12 create mode 100644 drivers/media/radio/wl128x/Kconfig
13 create mode 100644 drivers/media/radio/wl128x/Makefile
14
15diff --git a/drivers/media/radio/wl128x/Kconfig b/drivers/media/radio/wl128x/Kconfig
16new file mode 100644
17index 0000000..749f67b
18--- /dev/null
19+++ b/drivers/media/radio/wl128x/Kconfig
20@@ -0,0 +1,17 @@
21+#
22+# TI's wl128x FM driver based on TI's ST driver.
23+#
24+menu "Texas Instruments WL128x FM driver (ST based)"
25+config RADIO_WL128X
26+ tristate "Texas Instruments WL128x FM Radio"
27+ depends on VIDEO_V4L2 && RFKILL
28+ select TI_ST
29+ help
30+ Choose Y here if you have this FM radio chip.
31+
32+ In order to control your radio card, you will need to use programs
33+ that are compatible with the Video For Linux 2 API. Information on
34+ this API and pointers to "v4l2" programs may be found at
35+ <file:Documentation/video4linux/API.html>.
36+
37+endmenu
38diff --git a/drivers/media/radio/wl128x/Makefile b/drivers/media/radio/wl128x/Makefile
39new file mode 100644
40index 0000000..32a0ead
41--- /dev/null
42+++ b/drivers/media/radio/wl128x/Makefile
43@@ -0,0 +1,6 @@
44+#
45+# Makefile for TI's shared transport driver based wl128x
46+# FM radio.
47+#
48+obj-$(CONFIG_RADIO_WL128X) += fm_drv.o
49+fm_drv-objs := fmdrv_common.o fmdrv_rx.o fmdrv_tx.o fmdrv_v4l2.o
50--
511.6.6.1
52