summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-davinci_git.bb44
1 files changed, 2 insertions, 42 deletions
diff --git a/recipes-kernel/linux/linux-davinci_git.bb b/recipes-kernel/linux/linux-davinci_git.bb
index 04e92ba6..1fda1ee9 100644
--- a/recipes-kernel/linux/linux-davinci_git.bb
+++ b/recipes-kernel/linux/linux-davinci_git.bb
@@ -3,10 +3,9 @@ require multi-kernel.inc
3DESCRIPTION = "Linux kernel for DaVinci processors" 3DESCRIPTION = "Linux kernel for DaVinci processors"
4KERNEL_IMAGETYPE = "uImage" 4KERNEL_IMAGETYPE = "uImage"
5 5
6COMPATIBLE_MACHINE = "(dm355-evm|dm365-evm|dm6446-evm|dm6467-evm|dm6467t-evm|omapl137|omapl138|dm355-leopard|davinci-sffsdr|hawkboard)" 6COMPATIBLE_MACHINE = "hawkboard"
7 7
8DEFAULT_PREFERENCE = "1" 8DEFAULT_PREFERENCE_hawkboard = "1"
9DEFAULT_PREFERENCE_dm365 = "-1"
10 9
11BRANCH = "master" 10BRANCH = "master"
12 11
@@ -14,36 +13,6 @@ SRC_URI_append = " file://defconfig "
14 13
15S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
16 15
17# DaVinci DM3xx/DM6xxx
18# dm355-evm/dm365-evm/dm6446-evm/dm6467-evm/dm6467t-evm Davinci PSP 03.01.00/03.02.00 (build r30)
19# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
20
21ARAGO_DM_REV = "e87a8397d2830db11ce1518bd2abc4e8815763f1"
22ARAGO_DM_PV = "2.6.31+2.6.32-rc2-${PR}+gitr${SRCREV}"
23ARAGO_DM_BR = "r32"
24ARAGO_DM_URI = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git;branch=${BRANCH} "
25
26SRCREV_dm355 = ${ARAGO_DM_REV}
27SRCREV_dm365 = ${ARAGO_DM_REV}
28SRCREV_dm6446 = ${ARAGO_DM_REV}
29SRCREV_dm6467 = ${ARAGO_DM_REV}
30
31PV_dm355 = ${ARAGO_DM_PV}
32PV_dm365 = ${ARAGO_DM_PV}
33PV_dm6446 = ${ARAGO_DM_PV}
34PV_dm6467 = ${ARAGO_DM_PV}
35
36BRANCH_dm355 = ${ARAGO_DM_BR}
37BRANCH_dm365 = ${ARAGO_DM_BR}
38BRANCH_dm6446 = ${ARAGO_DM_BR}
39BRANCH_dm6467 = ${ARAGO_DM_BR}
40
41SRC_URI_append_dm355 = ${ARAGO_DM_URI}
42SRC_URI_append_dm365 = ${ARAGO_DM_URI}
43SRC_URI_append_dm6446 = ${ARAGO_DM_URI}
44SRC_URI_append_dm6467 = ${ARAGO_DM_URI}
45
46
47# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc 16# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
48 17
49# OMAPL tracking master branch - PSP 3.20.00.12 18# OMAPL tracking master branch - PSP 3.20.00.12
@@ -53,17 +22,12 @@ ARAGO_L1_BR = "master"
53ARAGO_L1_PV = "2.6.32+2.6.33-rc4-${PR}+gitr${SRCREV}" 22ARAGO_L1_PV = "2.6.32+2.6.33-rc4-${PR}+gitr${SRCREV}"
54ARAGO_L1_URI = "git://arago-project.org/git/projects/linux-omapl1.git;protocol=git;branch=${BRANCH} " 23ARAGO_L1_URI = "git://arago-project.org/git/projects/linux-omapl1.git;protocol=git;branch=${BRANCH} "
55 24
56SRCREV_omapl137 = ${ARAGO_L1_REV}
57SRCREV_omapl138 = ${ARAGO_L1_REV}
58SRCREV_hawkboard = ${ARAGO_L1_REV} 25SRCREV_hawkboard = ${ARAGO_L1_REV}
59 26
60PV_omapl137 = ${ARAGO_L1_PV}
61PV_omapl138 = ${ARAGO_L1_PV} 27PV_omapl138 = ${ARAGO_L1_PV}
62 28
63BRANCH_omapl137 = ${ARAGO_L1_BR}
64BRANCH_omapl138 = ${ARAGO_L1_BR} 29BRANCH_omapl138 = ${ARAGO_L1_BR}
65 30
66SRC_URI_append_omapl137 = ${ARAGO_L1_URI}
67SRC_URI_append_omapl138 = ${ARAGO_L1_URI} 31SRC_URI_append_omapl138 = ${ARAGO_L1_URI}
68 32
69SRC_URI_append_omapl138 = " file://logo_linux_clut224.ppm \ 33SRC_URI_append_omapl138 = " file://logo_linux_clut224.ppm \
@@ -82,10 +46,6 @@ SRC_URI_append_hawkboard = " \
82 file://0001-board-da850-hawk-Disable-NAND-SUBPAGE.patch \ 46 file://0001-board-da850-hawk-Disable-NAND-SUBPAGE.patch \
83 " 47 "
84 48
85do_configure_prepend_dm355-leopard() {
86 sed -i s:2138:1381:g ${S}/arch/arm/tools/mach-types
87}
88
89# Perf in 2.6.33rc has broken perl handling, so disable it 49# Perf in 2.6.33rc has broken perl handling, so disable it
90do_compile_perf() { 50do_compile_perf() {
91 : 51 :