diff options
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 58 | ||||
-rw-r--r--[-rwxr-xr-x] | recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh (renamed from recipes-ti/ipc/files/tiipclad-daemon.sh) | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_3.00.00.bb | 51 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_3.21.00.07.bb | 31 |
4 files changed, 64 insertions, 78 deletions
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc new file mode 100644 index 00000000..ee9fefff --- /dev/null +++ b/recipes-ti/ipc/ti-ipc.inc | |||
@@ -0,0 +1,58 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" | ||
2 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" | ||
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=f2518e421e230f06fe6d449718d02edc" | ||
6 | |||
7 | DEPENDS += "virtual/kernel" | ||
8 | |||
9 | PR = "r1" | ||
10 | |||
11 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
12 | |||
13 | PLATFORM = "UNKNOWN" | ||
14 | PLATFORM_omap5-evm = "OMAP54XX" | ||
15 | PLATFORM_dra7xx-evm = "DRA7XX" | ||
16 | PLATFORM_keystone = "TCI6638" | ||
17 | |||
18 | DAEMON = "UNKNOWN" | ||
19 | DAEMON_omap5-evm = "lad_omap54xx_smp" | ||
20 | DAEMON_dra7xx-evm = "lad_dra7xx" | ||
21 | DAEMON_keystone = "lad_tci6638" | ||
22 | |||
23 | inherit autotools pkgconfig update-rc.d | ||
24 | |||
25 | SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git \ | ||
26 | file://0002-ipc-Added-installation-prefix-feature-to-products.ma.patch \ | ||
27 | file://tiipclad-daemon.sh \ | ||
28 | " | ||
29 | |||
30 | S = "${WORKDIR}/git" | ||
31 | |||
32 | INITSCRIPT_NAME = "tiipclad-daemon.sh" | ||
33 | INITSCRIPT_PARAMS = "defaults 10" | ||
34 | |||
35 | EXTRA_OEMAKE += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_INSTALL_DIR=${TOOLCHAIN_PATH} TOOLCHAIN_LONGNAME=${TOOLCHAIN_SYS} PLATFORM=${PLATFORM} PREFIX=${prefix}" | ||
36 | |||
37 | do_configure() { | ||
38 | oe_runmake -f ${S}/ipc-linux.mak config | ||
39 | } | ||
40 | |||
41 | do_install_append() { | ||
42 | install -d ${D}${sysconfdir}/init.d/ | ||
43 | |||
44 | # Modify the tiipclad-daemon.sh script to point to the right | ||
45 | # lad daemon executable. | ||
46 | sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.sh | ||
47 | install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
48 | } | ||
49 | |||
50 | PACKAGES =+ "${PN}-test" | ||
51 | RDEPENDS_${PN}-test += "${PN}" | ||
52 | |||
53 | FILES_${PN}-test = " \ | ||
54 | ${bindir}/NameServerApp \ | ||
55 | ${bindir}/MessageQApp \ | ||
56 | ${bindir}/MessageQMulti \ | ||
57 | ${bindir}/ping_rpmsg" | ||
58 | |||
diff --git a/recipes-ti/ipc/files/tiipclad-daemon.sh b/recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh index 54b38882..97f870e8 100755..100644 --- a/recipes-ti/ipc/files/tiipclad-daemon.sh +++ b/recipes-ti/ipc/ti-ipc/tiipclad-daemon.sh | |||
@@ -1,6 +1,6 @@ | |||
1 | #! /bin/sh | 1 | #! /bin/sh |
2 | 2 | ||
3 | tiipclad_daemon=/usr/bin/lad_tci6638 | 3 | tiipclad_daemon=/usr/bin/__LAD_DAEMON__ |
4 | tiipclad_params=lad.txt | 4 | tiipclad_params=lad.txt |
5 | 5 | ||
6 | test -x "$tiipclad_daemon" || exit 0 | 6 | test -x "$tiipclad_daemon" || exit 0 |
diff --git a/recipes-ti/ipc/ti-ipc_3.00.00.bb b/recipes-ti/ipc/ti-ipc_3.00.00.bb index c07b7f9b..a6922c03 100644 --- a/recipes-ti/ipc/ti-ipc_3.00.00.bb +++ b/recipes-ti/ipc/ti-ipc_3.00.00.bb | |||
@@ -1,52 +1,7 @@ | |||
1 | DESCRIPTION="This support the communication between processors \ | 1 | require ti-ipc.inc |
2 | in a multi-processor environment and communication to peripherals. \ | ||
3 | This communication includes message passing, streams, and linked lists. \ | ||
4 | These modules work transparently in both uni-processor and multi-processor \ | ||
5 | configurations." | ||
6 | 2 | ||
7 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" | 3 | # For this version of IPC the PLATFORM value is lowercase |
4 | PLATFORM_keystone = "tci6638" | ||
8 | 5 | ||
9 | LICENSE = "BSD" | ||
10 | LIC_FILES_CHKSUM = "file://products.mak;beginline=2;endline=30;md5=195feadf798bb4165bcb1a23ffd50dbb" | ||
11 | SECTION = "console" | ||
12 | COMPATIBLE_MACHINE = "keystone" | ||
13 | TARGET_PLATFORM = "tci6638" | ||
14 | |||
15 | PR = "r0" | ||
16 | |||
17 | BRANCH ?= "master" | ||
18 | # The following commit corresponds to 3.00.04.29 | 6 | # The following commit corresponds to 3.00.04.29 |
19 | SRCREV = "12794ea33870b782bffe1fe4398e86e93fb64396" | 7 | SRCREV = "12794ea33870b782bffe1fe4398e86e93fb64396" |
20 | |||
21 | SRC_URI = " \ | ||
22 | git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH} \ | ||
23 | file://tiipclad-daemon.sh" | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | |||
27 | export PLATFORM = "${TARGET_PLATFORM}" | ||
28 | |||
29 | export PARALLEL_MAKE = "" | ||
30 | |||
31 | PACKAGES =+ "${PN}-test" | ||
32 | |||
33 | FILES_${PN}-test = " \ | ||
34 | ${bindir}/NameServerApp \ | ||
35 | ${bindir}/MessageQApp \ | ||
36 | ${bindir}/MessageQMulti \ | ||
37 | ${bindir}/ping_rpmsg" | ||
38 | |||
39 | DEPENDS += "virtual/kernel" | ||
40 | |||
41 | EXTRA_OECONF += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" | ||
42 | inherit autotools | ||
43 | |||
44 | INITSCRIPT_NAME = "tiipclad-daemon.sh" | ||
45 | INITSCRIPT_PARAMS = "defaults 10" | ||
46 | |||
47 | inherit update-rc.d | ||
48 | |||
49 | do_install_append() { | ||
50 | install -d ${D}${sysconfdir}/init.d/ | ||
51 | install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
52 | } | ||
diff --git a/recipes-ti/ipc/ti-ipc_3.21.00.07.bb b/recipes-ti/ipc/ti-ipc_3.21.00.07.bb index 8131754d..17cdab0e 100644 --- a/recipes-ti/ipc/ti-ipc_3.21.00.07.bb +++ b/recipes-ti/ipc/ti-ipc_3.21.00.07.bb | |||
@@ -1,31 +1,4 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" | 1 | require ti-ipc.inc |
2 | HOMEPAGE = "https://git.ti.com/ipc/pages/Home" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=f2518e421e230f06fe6d449718d02edc" | ||
5 | |||
6 | DEPENDS += "virtual/kernel" | ||
7 | |||
8 | PR = "r1" | ||
9 | |||
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
11 | |||
12 | PLATFORM_omap5-evm = "OMAP54XX" | ||
13 | PLATFORM_dra7xx-evm = "DRA7XX" | ||
14 | |||
15 | inherit autotools pkgconfig | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git \ | ||
18 | file://0002-ipc-Added-installation-prefix-feature-to-products.ma.patch \ | ||
19 | " | ||
20 | 2 | ||
3 | # This commit corresponds to 3.21.00.07 | ||
21 | SRCREV = "c18fece0c9f0dc76361dc1ee11b7ee2417479847" | 4 | SRCREV = "c18fece0c9f0dc76361dc1ee11b7ee2417479847" |
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | FILESEXTRAPATHS_prepend := "${THISDIR}:" | ||
26 | |||
27 | EXTRA_OEMAKE += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_INSTALL_DIR=${TOOLCHAIN_PATH} TOOLCHAIN_LONGNAME=${TOOLCHAIN_SYS} PLATFORM=${PLATFORM} PREFIX=${prefix}" | ||
28 | |||
29 | do_configure() { | ||
30 | oe_runmake -f ${S}/ipc-linux.mak config | ||
31 | } | ||