summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-bsp/conf/machine/include/omapl1.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/omapl138.inc14
-rw-r--r--meta-ti-bsp/conf/machine/omapl138-lcdk.conf1
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/bundle-devicetree.inc26
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb1
-rw-r--r--meta-ti-extras/recipes-ti/includes/ti-paths.inc3
7 files changed, 13 insertions, 35 deletions
diff --git a/meta-ti-bsp/conf/machine/include/omapl1.inc b/meta-ti-bsp/conf/machine/include/omapl1.inc
deleted file mode 100644
index d0262c3f..00000000
--- a/meta-ti-bsp/conf/machine/include/omapl1.inc
+++ /dev/null
@@ -1,2 +0,0 @@
1require conf/machine/include/ti-soc.inc
2SOC_FAMILY:append = ":omapl1"
diff --git a/meta-ti-bsp/conf/machine/include/omapl138.inc b/meta-ti-bsp/conf/machine/include/omapl138.inc
index c6eb0cd9..2e4a47a5 100644
--- a/meta-ti-bsp/conf/machine/include/omapl138.inc
+++ b/meta-ti-bsp/conf/machine/include/omapl138.inc
@@ -1,2 +1,14 @@
1require conf/machine/include/omapl1.inc 1require conf/machine/include/ti-soc.inc
2SOC_FAMILY:append = ":omapl138" 2SOC_FAMILY:append = ":omapl138"
3
4require conf/machine/include/arm/armv5/tune-arm926ejs.inc
5
6KERNEL_IMAGETYPE = "zImage"
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-ti-staging"
9PREFERRED_PROVIDER_virtual/bootloader = "u-boot-ti-staging"
10PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
11
12EXTRA_IMAGEDEPENDS += "virtual/bootloader"
13
14MACHINE_FEATURES = "kernel26 serial ethernet usbhost usbgadget mmc alsa"
diff --git a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf
index ba4d5645..b318f82d 100644
--- a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf
+++ b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf
@@ -2,7 +2,6 @@
2#@NAME: OMAP-L138 LCDK 2#@NAME: OMAP-L138 LCDK
3#@DESCRIPTION: Machine configuration for the TI OMAP-L138 LCDK board 3#@DESCRIPTION: Machine configuration for the TI OMAP-L138 LCDK board
4 4
5require conf/machine/include/davinci.inc
6require conf/machine/include/omapl138.inc 5require conf/machine/include/omapl138.inc
7 6
8UBOOT_MACHINE = "omapl138_lcdk_config" 7UBOOT_MACHINE = "omapl138_lcdk_config"
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index 31e1031d..5127e137 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -55,7 +55,6 @@ SYSROOT_DIRS += "/boot"
55# SPL (Second Program Loader) to be loaded over UART 55# SPL (Second Program Loader) to be loaded over UART
56SPL_UART_BINARY = "u-boot-spl.bin" 56SPL_UART_BINARY = "u-boot-spl.bin"
57SPL_UART_BINARY:k3r5 = "" 57SPL_UART_BINARY:k3r5 = ""
58SPL_UART_BINARY:lego-ev3 = ""
59 58
60SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" 59SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
61SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" 60SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
diff --git a/meta-ti-bsp/recipes-kernel/linux/bundle-devicetree.inc b/meta-ti-bsp/recipes-kernel/linux/bundle-devicetree.inc
deleted file mode 100644
index d259e58c..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/bundle-devicetree.inc
+++ /dev/null
@@ -1,26 +0,0 @@
1# Upstream kernel-devicetree.bbclass only supports bundling the DTB with
2# zImage. The factory u-boot on lego-ev3 EEPROM only supports uImage, so we
3# append the DTB to the final uImage here.
4
5do_deploy:append() {
6 if [ "${KERNEL_DEVICETREE_BUNDLE}" = "1" ]; then
7 install -d ${DEPLOYDIR}
8 for dtbf in ${KERNEL_DEVICETREE}; do
9 dtb=`normalize_dtb "$dtbf"`
10 dtb_ext=${dtb##*.}
11 dtb_base_name=`basename $dtb .$dtb_ext`
12 for type in ${KERNEL_IMAGETYPE_FOR_MAKE}; do
13 if [ "$type" = "uImage" ]; then
14 cat ${D}/${KERNEL_IMAGEDEST}/$type \
15 ${DEPLOYDIR}/$dtb_base_name-${KERNEL_DTB_NAME}.$dtb_ext \
16 > ${DEPLOYDIR}/$type-$dtb_base_name-${KERNEL_DTB_NAME}.$dtb_ext.bin
17 ln -sf $type-$dtb_base_name-${KERNEL_DTB_NAME}.$dtb_ext.bin \
18 ${DEPLOYDIR}/$type-$dtb_base_name-${KERNEL_DTB_LINK_NAME}.$dtb_ext.bin
19 cat ${D}/${KERNEL_IMAGEDEST}/$type \
20 ${DEPLOYDIR}/$dtb_base_name-${KERNEL_DTB_NAME}.$dtb_ext \
21 > ${DEPLOYDIR}/$type
22 fi
23 done
24 done
25 fi
26}
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index a0af03c5..bf230dbc 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -8,7 +8,6 @@ inherit kernel
8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" 8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/ti-uio.inc 10require recipes-kernel/linux/ti-uio.inc
11require recipes-kernel/linux/bundle-devicetree.inc
12require recipes-kernel/linux/kernel-rdepends.inc 11require recipes-kernel/linux/kernel-rdepends.inc
13require recipes-kernel/linux/ti-kernel.inc 12require recipes-kernel/linux/ti-kernel.inc
14 13
diff --git a/meta-ti-extras/recipes-ti/includes/ti-paths.inc b/meta-ti-extras/recipes-ti/includes/ti-paths.inc
index 5994ff0a..63c00e8c 100644
--- a/meta-ti-extras/recipes-ti/includes/ti-paths.inc
+++ b/meta-ti-extras/recipes-ti/includes/ti-paths.inc
@@ -104,8 +104,5 @@ export TI_CGT7X_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT7X_INSTALL_DI
104export TI_K3_SECDEV_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}" 104export TI_K3_SECDEV_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}"
105 105
106 106
107DSPSUFFIX:omapl137 = "x674"
108DSPSUFFIX:omapl138 = "x674" 107DSPSUFFIX:omapl138 = "x674"
109DSPSUFFIX_ti816x = "xe674"
110DSPSUFFIX_ti814x = "xe674"
111DSPSUFFIX ?= "x64P" 108DSPSUFFIX ?= "x64P"