summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch31
-rw-r--r--meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb5
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch
new file mode 100644
index 00000000..1e897394
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv/0002-Support-Linux-kernels-v6.6.patch
@@ -0,0 +1,31 @@
1From: Ryan Eatmon <reatmon@ti.com>
2Date: Wed, 08 Feb 2024 10:43:00 -0500
3Subject: [PATCH] Support Linux kernels v6.6+
4
5gdb_write arg changed from int to unsigned int
6
7Upstream-Status: Inactive-Upstream
8
9Signed-off-by: Ryan Eatmon <reatmon@ti.com>
10---
11 kernel_module/gdbproxy-mod/gdbserverproxy.c | 6 +++++-
12 1 file changed, 5 insertions(+), 1 deletion(-)
13
14diff --git a/kernel_module/gdbproxy-mod/gdbserverproxy.c b/kernel_module/gdbproxy-mod/gdbserverproxy.c
15index 418b6db..4b1c676 100644
16--- a/kernel_module/gdbproxy-mod/gdbserverproxy.c
17+++ b/kernel_module/gdbproxy-mod/gdbserverproxy.c
18@@ -496,8 +496,13 @@ static void gdb_close(struct tty_struct *tty, struct file *filp)
19 *
20 *
21 */
22+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(6,6,0))
23+static int gdb_write(struct tty_struct *tty,
24+ const unsigned char *buf, unsigned int count)
25+#else
26 static int gdb_write(struct tty_struct *tty,
27 const unsigned char *buf, int count)
28+#endif
29 {
30 struct dsp_session *dsp = tty->driver_data;
31 int ret = 0;
diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
index 60492f81..b68c4463 100644
--- a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
@@ -7,7 +7,10 @@ MACHINE_KERNEL_PR:append = "b"
7PR = "${MACHINE_KERNEL_PR}" 7PR = "${MACHINE_KERNEL_PR}"
8PV:append = "+git${SRCPV}" 8PV:append = "+git${SRCPV}"
9 9
10SRC_URI:append = " file://0001-Support-Linux-kernels-v5.15.patch;patchdir=../.." 10SRC_URI:append = "\
11 file://0001-Support-Linux-kernels-v5.15.patch;patchdir=../.. \
12 file://0002-Support-Linux-kernels-v6.6.patch;patchdir=../.. \
13"
11 14
12S = "${WORKDIR}/git/kernel_module/gdbproxy-mod" 15S = "${WORKDIR}/git/kernel_module/gdbproxy-mod"
13 16