summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 01ef7a00..f4eefa85 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -72,8 +72,35 @@ do_install() {
72 cp ${CP_ARGS} ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true 72 cp ${CP_ARGS} ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true
73} 73}
74 74
75KFDSPNUM = "0"
76KFDSPNUM_k2hk = "8"
77KFDSPNUM_k2l-evm = "4"
78KFDSPNUM_keystone = "1"
79
80KFPLAT = ""
81KFPLAT_k2hk = "TCI6638K2K"
82KFPLAT_k2l-evm = "TCI6630K2L"
83KFPLAT_k2e = "C66AK2E"
84KFPLAT_k2g = "TCI66AK2G02"
85
75ALTERNATIVE_PRIORITY = "5" 86ALTERNATIVE_PRIORITY = "5"
76 87
88pkg_postinst_${PN}-fw_keystone () {
89 i=0
90 while [ $i -lt ${KFDSPNUM} ]; do
91 update-alternatives --install /lib/firmware/keystone-dsp$i-fw keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66 ${ALTERNATIVE_PRIORITY}
92 i=$(($i + 1))
93 done
94}
95
96pkg_postrm_${PN}-fw_keystone () {
97 i=0
98 while [ $i -lt ${KFDSPNUM} ]; do
99 update-alternatives --remove keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66
100 i=$(($i + 1))
101 done
102}
103
77pkg_postinst_${PN}-fw_omap-a15 () { 104pkg_postinst_${PN}-fw_omap-a15 () {
78 update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY} 105 update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY}
79 update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY} 106 update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY}