summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb3
-rw-r--r--recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch42
2 files changed, 1 insertions, 44 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index e4ea67f6..1b6f3206 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -8,7 +8,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
8DEPENDS = "u-boot-mkimage-native" 8DEPENDS = "u-boot-mkimage-native"
9 9
10SRC_URI = "git://git.ti.com/processor-firmware/ks2-boot-monitor.git;protocol=git;branch=${BRANCH}" 10SRC_URI = "git://git.ti.com/processor-firmware/ks2-boot-monitor.git;protocol=git;branch=${BRANCH}"
11SRC_URI += "file://0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch"
12 11
13PV = "4.0+git${SRCPV}" 12PV = "4.0+git${SRCPV}"
14 13
@@ -16,7 +15,7 @@ BRANCH = "master"
16 15
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17
19SRCREV = "d7b2bbd419400228da621f445526e519b56aef93" 18SRCREV = "e1f885ab6dc544884728e333cc6e396f7eb08286"
20 19
21BOOT_MONITOR_IMAGE ?= "skern-${BOOT_MONITOR_MAKE_TARGET}.bin" 20BOOT_MONITOR_IMAGE ?= "skern-${BOOT_MONITOR_MAKE_TARGET}.bin"
22 21
diff --git a/recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch b/recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch
deleted file mode 100644
index ae6d25ca..00000000
--- a/recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From f22f18d426c8f5b70c0bce9ac6015c067c46f5ad Mon Sep 17 00:00:00 2001
2From: Dan Murphy <dmurphy@ti.com>
3Date: Mon, 24 Apr 2017 17:02:56 -0500
4Subject: [PATCH] makedefs: Fix issue with setting CHECK and VERBOSE
5
6Within the ifndef tabs are not allowed. These need
7to be converted to spaces. Without this CHECK is always
8set and sparse is expected to be installed.
9
10Fixes: aba308b9868d ("Makefile: Use OBJROOT for build output to enable out-of-tree builds")
11Reported-by: Denys Dmytriyenko <denys@ti.com>
12Signed-off-by: Dan Murphy <dmurphy@ti.com>
13Signed-off-by: Denys Dmytriyenko <denys@ti.com>
14---
15 makedefs | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/makedefs b/makedefs
19index 1c4e2a5..ab710c3 100644
20--- a/makedefs
21+++ b/makedefs
22@@ -58,7 +58,7 @@ ifeq ("$(origin C)", "command line")
23 endif
24
25 ifndef VERBOSE
26- export VERBOSE=0
27+ export VERBOSE=0
28 endif
29
30 ifeq ($(VERBOSE),1)
31@@ -69,7 +69,7 @@ else
32 endif
33
34 ifndef CHECK
35- export CHECK=0
36+ export CHECK=0
37 endif
38
39 Q_CC=$(Q:@=@echo ' CC '$@;)$(CC)
40--
412.7.4
42