summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch34
-rw-r--r--recipes-security/optee/optee-os_%.bbappend6
2 files changed, 39 insertions, 1 deletions
diff --git a/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch b/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
new file mode 100644
index 00000000..1698c904
--- /dev/null
+++ b/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
@@ -0,0 +1,34 @@
1From 0bab935695ebcf0c533b49896ab18ff33d4a47d1 Mon Sep 17 00:00:00 2001
2From: Ross Burton <ross.burton@arm.com>
3Date: Tue, 26 May 2020 14:38:02 -0500
4Subject: [PATCH] allow setting sysroot for libgcc lookup
5
6Explicitly pass the new variable LIBGCC_LOCATE_CFLAGS variable when searching
7for the compiler libraries as there's no easy way to reliably pass --sysroot
8otherwise.
9
10Upstream-Status: Pending [https://github.com/OP-TEE/optee_os/issues/4188]
11Signed-off-by: Ross Burton <ross.burton@arm.com>
12---
13 mk/gcc.mk | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/mk/gcc.mk b/mk/gcc.mk
17index adc77a24..81bfa78a 100644
18--- a/mk/gcc.mk
19+++ b/mk/gcc.mk
20@@ -13,11 +13,11 @@ nostdinc$(sm) := -nostdinc -isystem $(shell $(CC$(sm)) \
21 -print-file-name=include 2> /dev/null)
22
23 # Get location of libgcc from gcc
24-libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \
25+libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \
26 -print-libgcc-file-name 2> /dev/null)
27-libstdc++$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
28+libstdc++$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
29 -print-file-name=libstdc++.a 2> /dev/null)
30-libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
31+libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
32 -print-file-name=libgcc_eh.a 2> /dev/null)
33
34 # Define these to something to discover accidental use
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index ddfc76f1..ebcf584d 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -1,6 +1,10 @@
1FILESEXTRAPATHS_prepend_ti-soc := "${THISDIR}/${PN}:"
2
1PV_ti-soc = "3.20.0+git${SRCPV}" 3PV_ti-soc = "3.20.0+git${SRCPV}"
2SRCREV_ti-soc = "8e74d47616a20eaa23ca692f4bbbf917a236ed94" 4SRCREV_ti-soc = "8e74d47616a20eaa23ca692f4bbbf917a236ed94"
3SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https" 5SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https \
6file://0006-allow-setting-sysroot-for-libgcc-lookup.patch \
7"
4 8
5DEPENDS_append_ti-soc = " python3-cryptography-native" 9DEPENDS_append_ti-soc = " python3-cryptography-native"
6 10