summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2016-11-30 03:35:15 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-06 19:44:19 -0500
commitc8ac370ef68a26efe182185268efef3219d49508 (patch)
treef8fbdadd63cef0933214e1a10653f4cf18e84903 /recipes-ti
parent420e25c4c8d4014783a0ead7a0db7fa51037fb0f (diff)
downloadmeta-ti-c8ac370ef68a26efe182185268efef3219d49508.tar.gz
ti-ipc: Add recipe to build ipc-examples
Builds both linux and RTOS IPC examples Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
new file mode 100644
index 00000000..019bffac
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -0,0 +1,86 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples"
2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
3require ti-ipc-common.inc
4require ti-ipc-rtos.inc
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02"
8
9DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos"
10
11INSANE_SKIP_${PN} += "arch"
12
13ALLOW_EMPTY_${PN} = "1"
14
15IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
16
17do_compile() {
18
19 cd ${S_ipc-examples}/src
20 oe_runmake .examples \
21 IPCTOOLS="${S_ipc-metadata}/src/etc"
22
23 if [ ! -z ${ALT_PLATFORM} ]; then
24 oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \
25 IPCTOOLS="${S_ipc-metadata}/src/etc"
26 echo test
27 fi
28 if [ "${PLATFORM}" != "UNKNOWN" ]; then
29 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
30 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
31
32 if [ ! -z ${ALT_PLATFORM} ]; then
33 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \
34 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
35 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
36 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
37 fi
38 oe_runmake -C examples all HOSTOS="bios" \
39 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
40 oe_runmake -C examples all HOSTOS="linux" \
41 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
42 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
43 if [ ! -z ${ALT_PLATFORM} ]; then
44 oe_runmake -C examples all HOSTOS="bios" \
45 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}"
46 oe_runmake -C examples all HOSTOS="linux" \
47 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
48 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
49 PLATFORM="${ALT_PLATFORM}"
50 echo testing
51 fi
52 fi
53}
54
55do_install() {
56 cd ${S_ipc-examples}/src
57 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
58
59 install -d ${D}/ipc_${IPC_VERSION}/examples
60 if [ "${PLATFORM}" != "UNKNOWN" ]; then
61 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
62 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples"
63 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
64 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples"
65
66 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
67 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
68 HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples"
69
70 if [ ! -z ${ALT_PLATFORM} ]; then
71 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
72 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \
73 PLATFORM="${ALT_PLATFORM}"
74 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
75 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \
76 PLATFORM="${ALT_PLATFORM}"
77
78 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
79 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
80 HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \
81 PLATFORM="${ALT_PLATFORM}"
82 fi
83 fi
84}
85
86FILES_${PN} += "ipc_*"