summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2017-04-20 03:02:10 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-04-24 12:44:27 -0400
commitc8502384f80cbef60ac61d13c5cc255f566e7bb8 (patch)
tree8276a275325bbc09148ee094478120986ed8f013 /recipes-ti
parent8a152857b7394db9524d1b11a1a522e9bb56abe8 (diff)
downloadmeta-ti-c8502384f80cbef60ac61d13c5cc255f566e7bb8.tar.gz
ti-ipc: Update to new verison 3.46.00.01_eng
Add support for omapl138 platforms Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc5
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc20
-rw-r--r--recipes-ti/ipc/ti-ipc.inc6
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb1
4 files changed, 22 insertions, 10 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index c5f28e7c..d0f3aa51 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
1PV = "3.45.00.00" 1PV = "3.46.00.01"
2INC_PR = "r1" 2INC_PR = "r0"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
5 5
@@ -10,5 +10,6 @@ PLATFORM_k2hk-evm = "TCI6638"
10PLATFORM_k2l-evm = "TCI6630" 10PLATFORM_k2l-evm = "TCI6630"
11PLATFORM_k2e = "66AK2E" 11PLATFORM_k2e = "66AK2E"
12PLATFORM_k2g = "66AK2G" 12PLATFORM_k2g = "66AK2G"
13PLATFORM_omapl138 = "OMAPL138"
13 14
14ALT_PLATFORM_k2hk-evm = "TCI6636" 15ALT_PLATFORM_k2hk-evm = "TCI6636"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index b29e984a..0d7e0e6b 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -28,16 +28,16 @@ name=${TI_IPC_METADATA_NAME}"
28# Corresponds to tag: 3.45.00.00 28# Corresponds to tag: 3.45.00.00
29SRCREV_ipc-examples = "3a8ee1841ec36117a9bcd3d45bb2781bbd53ecf8" 29SRCREV_ipc-examples = "3a8ee1841ec36117a9bcd3d45bb2781bbd53ecf8"
30 30
31# Corresponds to tag: 3.45.00.00 31# Corresponds to tag: 3.46.00.01_eng
32SRCREV_ipc-metadata = "30b83f09be1877f86b22c971d978cb478fc7dd6e" 32SRCREV_ipc-metadata = "a04b677e9c55bbffd4bd7071ab7dfb6dde3eb97f"
33 33
34S_ipc-examples = "${WORKDIR}/git/ipc-examples" 34S_ipc-examples = "${WORKDIR}/git/ipc-examples"
35S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" 35S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
36 36
37RELEASE_TYPE = "GA" 37RELEASE_TYPE = "ENG"
38RELEASE_SUFFIX = "" 38RELEASE_SUFFIX = "_eng"
39 39
40PR = "${INC_PR}.3" 40PR = "${INC_PR}.r0"
41 41
42DEPENDS_append_keystone = " ti-cgt6x-native \ 42DEPENDS_append_keystone = " ti-cgt6x-native \
43 gcc-arm-none-eabi-native \ 43 gcc-arm-none-eabi-native \
@@ -46,7 +46,12 @@ DEPENDS_append_omap-a15 = " ti-cgt6x-native \
46 ti-ccsv6-native \ 46 ti-ccsv6-native \
47 gcc-arm-none-eabi-native \ 47 gcc-arm-none-eabi-native \
48" 48"
49DEPENDS_append_omapl138 = " ti-cgt6x-native \
50 gcc-arm-none-eabi-native \
51"
52
49IPC_TARGETS = "" 53IPC_TARGETS = ""
54
50IPC_TARGETS_omap-a15 = "\ 55IPC_TARGETS_omap-a15 = "\
51 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ 56 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
52 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 57 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
@@ -54,6 +59,11 @@ IPC_TARGETS_omap-a15 = "\
54 ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \ 59 ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
55" 60"
56 61
62IPC_TARGETS_omapl138 = "\
63 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
64 ti.targets.elf.C674="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
65"
66
57IPC_TARGETS_keystone = " \ 67IPC_TARGETS_keystone = " \
58 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ 68 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
59 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 69 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index ea256d24..e2a91cf1 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
6 6
7TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" 7TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
8TI_IPC_GIT_PROTOCOL = "git" 8TI_IPC_GIT_PROTOCOL = "git"
9TI_IPC_GIT_BRANCH = "master" 9TI_IPC_GIT_BRANCH = "3.46"
10 10
11#Corresponds to 3.45.00.00 11#Corresponds to 3.46.00.01_eng
12TI_IPC_SRCREV = "1584985938884bf6cb1d839779578354b1865ea4" 12TI_IPC_SRCREV = "a404d6aac840b6170cf4e9d819738842ec91746e"
13 13
14BRANCH = "${TI_IPC_GIT_BRANCH}" 14BRANCH = "${TI_IPC_GIT_BRANCH}"
15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" 15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb
index 05b4d85d..ce2eee0a 100644
--- a/recipes-ti/ipc/ti-ipc_git.bb
+++ b/recipes-ti/ipc/ti-ipc_git.bb
@@ -20,6 +20,7 @@ DAEMON_k2hk-evm = "lad_tci6638"
20DAEMON_k2l-evm = "lad_tci6630" 20DAEMON_k2l-evm = "lad_tci6630"
21DAEMON_k2e = "lad_66ak2e" 21DAEMON_k2e = "lad_66ak2e"
22DAEMON_k2g = "lad_66ak2g" 22DAEMON_k2g = "lad_66ak2g"
23DAEMON_omapl138 = "lad_omapl138"
23 24
24inherit autotools-brokensep pkgconfig update-rc.d 25inherit autotools-brokensep pkgconfig update-rc.d
25 26